summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-26 08:14:38 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-26 08:14:38 +1200
commite6e7748ca3e32e8bb5efe5891cfbd7cf541d5865 (patch)
tree1c72bce57659d8c0433bd9e581eb4f010813c711
parentdev-perl/DateTime-Format-ISO8601: -r bump for EAPI7 (diff)
downloadgentoo-e6e7748ca3e32e8bb5efe5891cfbd7cf541d5865.tar.gz
gentoo-e6e7748ca3e32e8bb5efe5891cfbd7cf541d5865.tar.bz2
gentoo-e6e7748ca3e32e8bb5efe5891cfbd7cf541d5865.zip
dev-perl/DateTime-Format-Natural: Bump to version 1.100.0
- EAPI7 - Unconditionally patch bad tests Upstream: - Fix advancing to future when both datetime and prefer_future options are set. - Include time zone when constructing DateTime objects for the datetime option in dateparse - New supported format: <variant> quarter - New supported formats: <count> <unit> before/after noon/midnight - New supported format: <count> seconds/minutes before/after yesterday/today/tomorrow - Prefer futures even stronger with demand_future - Require newer Params::Validate - Support common unit abbreviations Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/DateTime-Format-Natural/DateTime-Format-Natural-1.100.0.ebuild47
-rw-r--r--dev-perl/DateTime-Format-Natural/Manifest1
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-perl/DateTime-Format-Natural/DateTime-Format-Natural-1.100.0.ebuild b/dev-perl/DateTime-Format-Natural/DateTime-Format-Natural-1.100.0.ebuild
new file mode 100644
index 000000000000..6858938e2fdc
--- /dev/null
+++ b/dev-perl/DateTime-Format-Natural/DateTime-Format-Natural-1.100.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SCHUBIGER
+DIST_VERSION=1.10
+inherit perl-module
+
+DESCRIPTION="Parse informal natural language date/time strings"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Clone
+ dev-perl/Date-Calc
+ dev-perl/DateTime
+ dev-perl/DateTime-TimeZone
+ virtual/perl-Exporter
+ virtual/perl-File-Spec
+ virtual/perl-Getopt-Long
+ dev-perl/List-MoreUtils
+ >=dev-perl/Params-Validate-1.150.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Storable
+ virtual/perl-Term-ReadLine
+ dev-perl/boolean
+"
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.420.0
+ test? (
+ dev-perl/Module-Util
+ dev-perl/Test-MockTime
+ virtual/perl-Test-Simple
+ )
+"
+PERL_RM_FILES=(
+ t/pod-coverage.t
+ t/pod.t
+)
diff --git a/dev-perl/DateTime-Format-Natural/Manifest b/dev-perl/DateTime-Format-Natural/Manifest
index d05dc6ed7fbd..262c74de7932 100644
--- a/dev-perl/DateTime-Format-Natural/Manifest
+++ b/dev-perl/DateTime-Format-Natural/Manifest
@@ -1 +1,2 @@
DIST DateTime-Format-Natural-1.05.tar.gz 80675 BLAKE2B 7495309aecc2aca50dcbcbbd7732cffac593a1455a438ada473c9cd0b4c068d4ac5f7dd59632d63e07b3b4c05d6d2cb8826996a047a618eb4a3f4f3fb4a29f85 SHA512 d6c07a7e6345321dfffbf608fbd0ef8b050761b612f76ebb0cf06b9e883ca83863b71f846868c8323d6d0c428c9ec93a988bcb53f883045bd1de94926cba9e7e
+DIST DateTime-Format-Natural-1.10.tar.gz 80958 BLAKE2B 1d1fc1b4f1aae0e9bc359768960896d3d7da548051886789c21993854a2d550dc1c85e202dc714708a99aa09d26823773c6311f5fd33d91ec1844d5226c6e37d SHA512 41d51364efe242733945bca061fe67562fe24f069788d14962aeb2a5d0589e9078f81212d0fde78e950050853eaed5e1a0cc3868f409b82c7b054849c9dc2600