summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-12-18 14:27:27 -0500
committerMichael Orlitzky <mjo@gentoo.org>2016-12-18 14:27:42 -0500
commite8b29eb86eea183639c9ed2ce5c0010d99faa93f (patch)
tree4dfa338c88d99d18bc51bd57240f0d169ce384d7
parentsys-boot/unetbootin: Old. (diff)
downloadgentoo-e8b29eb86eea183639c9ed2ce5c0010d99faa93f.tar.gz
gentoo-e8b29eb86eea183639c9ed2ce5c0010d99faa93f.tar.bz2
gentoo-e8b29eb86eea183639c9ed2ce5c0010d99faa93f.zip
dev-php/libchart: replace snapshot with final v1.3 release.
We temporarily had a snapshot in the tree as a precaution against the demise of Google Code. Now that the final v1.3 release has been added to Github, we use that instead. Package-Manager: portage-2.3.0
-rw-r--r--dev-php/libchart/Manifest2
-rw-r--r--dev-php/libchart/libchart-1.3.ebuild32
-rw-r--r--dev-php/libchart/libchart-1.3_p21050415.ebuild44
3 files changed, 33 insertions, 45 deletions
diff --git a/dev-php/libchart/Manifest b/dev-php/libchart/Manifest
index e0ceb67ed1e9..180e6ad57c92 100644
--- a/dev-php/libchart/Manifest
+++ b/dev-php/libchart/Manifest
@@ -1 +1 @@
-DIST libchart-1.3_p21050415.tar.gz 365928 SHA256 c39eb5060b37a21883d405064bc49d2b1971208f9634e96cdb2d329d2f07a20d SHA512 14579fb69dd6c2f08725391773268221158d2ba065dd47e116895a543dfb990de3d26757d6f3e17da5ed8a33c5a728efe0ccca079517c8381b37ea6cef083be5 WHIRLPOOL 239cb88c13683182fc9bf2d7a99d91b84a1d0e2c7324357d1838b353ac93327cb1e485ec4a3d5fd906202a5cc51449ded125e963b0d747bf5c769353a2848a2d
+DIST libchart-1.3.tar.gz 106204 SHA256 ab3bdf1ccdb008a7ca9f7908d7ed8698163ab6679eaaf4bc37d5229471f38ac2 SHA512 5d2a0b014546487029f552f225fa83de856210a997e69bb5b129e99790f5acfdcfff904077126c42f82974d10f81e7e0342991221af5f108902b2792df24d586 WHIRLPOOL e4bb9b86939592a97bec0b00ebc26046a599a9b6d1ed266db9ad7b6b4a653cca21fdb7aa31078ba2d0957ddc0cc0c5741fd1d62a80b229b55f78dda81c2acca9
diff --git a/dev-php/libchart/libchart-1.3.ebuild b/dev-php/libchart/libchart-1.3.ebuild
new file mode 100644
index 000000000000..ff816e5809e0
--- /dev/null
+++ b/dev-php/libchart/libchart-1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Easy-to-use chart creation library for PHP"
+HOMEPAGE="http://naku.dohcrew.com/libchart https://github.com/naku/libchart"
+SRC_URI="https://github.com/naku/${PN}/releases/download/release/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3 BitstreamVera"
+KEYWORDS="~amd64 ~x86"
+SLOT=0
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="dev-lang/php:*[gd,truetype]"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ dodoc "${PN}"/{ChangeLog,README}
+
+ if use examples ; then
+ # PHP won't run a compressed example...
+ docompress -x "/usr/share/doc/${PF}/demo"
+ dodoc -r demo/
+ fi
+
+ insinto "/usr/share/php/${PN}"
+ doins -r "${PN}"/{classes,fonts,images}
+}
diff --git a/dev-php/libchart/libchart-1.3_p21050415.ebuild b/dev-php/libchart/libchart-1.3_p21050415.ebuild
deleted file mode 100644
index 5347dfd5ae07..000000000000
--- a/dev-php/libchart/libchart-1.3_p21050415.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="6"
-
-inherit vcs-snapshot
-
-DESCRIPTION="Libchart is a chart creation PHP library that is easy to use"
-HOMEPAGE="http://naku.dohcrew.com/libchart"
-SRC_URI="https://github.com/naku/libchart/archive/af1628453cc083ede980c78216da8f2f594da6fa.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3 BitstreamVera"
-KEYWORDS="~x86 ~amd64"
-SLOT=0
-IUSE="examples"
-
-DEPEND=""
-RDEPEND="dev-lang/php:*[gd,truetype]"
-
-DOCS=( ChangeLog README.md )
-
-src_install() {
- #remove extra license files
- rm -r "${S}/${PN}/doc" || die
- einstalldocs
-
- if use examples ; then
- # no point making users unzip all files individually
- docompress -x "/usr/share/doc/${PF}/demo"
- dodoc -r demo/
- fi
-
- insinto "/usr/share/php/${PN}"
- doins -r ${PN}/*
-}
-
-pkg_postinst() {
- elog
- elog "This version removes the duplicated /usr/share/php/libchart/libchart"
- elog "in favor of /usr/share/php/libchart. Please update any scripts in order"
- elog "for the classes to be found."
- elog
-}