summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-31 17:36:59 +0200
committerMichał Górny <mgorny@gentoo.org>2023-03-31 17:40:31 +0200
commite910b4a42f5f639b80288baeab124c431328085d (patch)
tree35cae915d8c263d213f8fa2823585ca6836ad683
parentnet-ftp/filezilla: drop workaround patch for wxGTK version (diff)
downloadgentoo-e910b4a42f5f639b80288baeab124c431328085d.tar.gz
gentoo-e910b4a42f5f639b80288baeab124c431328085d.tar.bz2
gentoo-e910b4a42f5f639b80288baeab124c431328085d.zip
dev-python/cheetah3: Bump to 3.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cheetah3/Manifest1
-rw-r--r--dev-python/cheetah3/cheetah3-3.3.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/cheetah3/Manifest b/dev-python/cheetah3/Manifest
index e848f2352855..ed709b024c0c 100644
--- a/dev-python/cheetah3/Manifest
+++ b/dev-python/cheetah3/Manifest
@@ -1 +1,2 @@
DIST cheetah3-3.2.6.post2.tar.gz 316291 BLAKE2B d5dfaa958bc0cc41097d4a75abfe092d51379efd644daa01caac6ba1b789c21334a662904166b6069a0204e302c1d9e7bea74aa9f11082b9c8fce1c1c509f888 SHA512 b10d2569ce92181029b8f95d23602ec7b002400c8fdf4f6bb095ff40201154b97418fec19c9920f2f212f545633571aa32dc50a16a9ba81a9427303ca7938f29
+DIST cheetah3-3.3.1.gh.tar.gz 315007 BLAKE2B 627cb435db1cf274861a29b993f49457c1ba4147b6e1514b5d5961a2fd565c39ff9cae3bcd9665379c5206dc2cef98a6bf159781e664d75d87fa8c4244ec4e43 SHA512 057d3772390076157a0e09e6b5e60ad0ec3b1669aa62741bcfd314f846bba091884d361382d6399e73bce06aaf49366ee3cbeb040c6f5b3e00423eefd440c300
diff --git a/dev-python/cheetah3/cheetah3-3.3.1.ebuild b/dev-python/cheetah3/cheetah3-3.3.1.ebuild
new file mode 100644
index 000000000000..8ac112ebae33
--- /dev/null
+++ b/dev-python/cheetah3/cheetah3-3.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Python-powered template engine and code generator"
+HOMEPAGE="
+ https://cheetahtemplate.org/
+ https://github.com/CheetahTemplate3/Cheetah3/
+ https://pypi.org/project/Cheetah3/
+"
+SRC_URI="
+ https://github.com/CheetahTemplate3/Cheetah3/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+SLOT="0"
+
+RDEPEND="
+ dev-python/markdown[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( ANNOUNCE.rst README.rst TODO )
+
+python_test() {
+ # the package can't handle TMPDIR with hyphens
+ # https://github.com/CheetahTemplate3/cheetah3/issues/53
+ local -x TMPDIR=/tmp
+
+ "${EPYTHON}" Cheetah/Tests/Test.py || die "Tests fail with ${EPYTHON}"
+}