summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-05 10:15:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-05 11:25:31 +0200
commitebff6b7ef7d782ca15901876eb5f841365b1bfcf (patch)
tree6262efa795d4eac763f4bbb7f892c33f57d2f8c6
parentdev-python/pymongo: Bump to 3.11.4 (diff)
downloadgentoo-ebff6b7ef7d782ca15901876eb5f841365b1bfcf.tar.gz
gentoo-ebff6b7ef7d782ca15901876eb5f841365b1bfcf.tar.bz2
gentoo-ebff6b7ef7d782ca15901876eb5f841365b1bfcf.zip
dev-python/pykka: Bump to 3.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pykka/Manifest1
-rw-r--r--dev-python/pykka/pykka-3.0.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pykka/Manifest b/dev-python/pykka/Manifest
index aa6fce924df3..654c85f4ce30 100644
--- a/dev-python/pykka/Manifest
+++ b/dev-python/pykka/Manifest
@@ -1,2 +1,3 @@
DIST Pykka-2.0.2.tar.gz 51858 BLAKE2B 62132a3ded257d44d9504258418abc73ec9cc09353ab8e1948c9910fc11f67f770510b2dc7cf122db9af9ff62091757b648dce69cbdab0ffc17567169749d0d2 SHA512 98b2e6122dc5158da489265cf7cf9e358bfa432d0a0eaab9f50a07c0050083afb19aad494e4cd27347c376947eafb7d9796909c18e3648ef1bf0685bd6384e5b
DIST Pykka-2.0.3.tar.gz 55749 BLAKE2B 5da98dcc786c2bb7728485e16090b8dad7a96858aa86f024564286bb03d3faa93673ed3db87882e3dc6555a5b64c9c62433ab782ceb94e89965fa870bbb78d2f SHA512 0f4d6d9e0c92a7e7cafb340f343afa1e78bcefdd0454341d3f457fa202acdd3de979881689cb3cd5f2cbd3a08f80177f6470db4fb895b20d9c1b4d0b9ef627ee
+DIST pykka-3.0.1.gh.tar.gz 59252 BLAKE2B fd0ca0742f3c372a5983d01929b34587390929fae28b70e0ee939f651f7655bb924ae08fac039225a8040c9bf523177af7bf3fa7c1db6ea1f04ec460cc3a1c6a SHA512 c96503019a190663cd4054c2488668143ff5d0d92b0c2d1ab3df577ab9fc9f0f2f575677a9f955a7b940e725d588c0caa6097515f1236df9a453fb3b0a2cb8c8
diff --git a/dev-python/pykka/pykka-3.0.1.ebuild b/dev-python/pykka/pykka-3.0.1.ebuild
new file mode 100644
index 000000000000..1d0432f40a8c
--- /dev/null
+++ b/dev-python/pykka/pykka-3.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python implementation of the actor model"
+HOMEPAGE="
+ https://www.pykka.org/en/latest/
+ https://github.com/jodal/pykka/"
+SRC_URI="
+ https://github.com/jodal/pykka/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' python3_7)"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest