summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-12-18 20:33:40 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-12-18 20:33:59 +0100
commitec1d210e7d85aba515fe6519601c95f03337ade2 (patch)
treea33a477f1385b6324005b7c1547690d67ce26c8b
parentmedia-sound/clementine: Fix DEPENDs, LINGUAS (diff)
downloadgentoo-ec1d210e7d85aba515fe6519601c95f03337ade2.tar.gz
gentoo-ec1d210e7d85aba515fe6519601c95f03337ade2.tar.bz2
gentoo-ec1d210e7d85aba515fe6519601c95f03337ade2.zip
sys-fs/quota: Require glibc without rpc support if rpc support is selected here, bug 636934
Otherwise we get file collisions: * sys-libs/glibc-2.25-r9:2.2::gentoo * /usr/include/rpcsvc/rquota.h * /usr/include/rpcsvc/rquota.x Closes: https://bugs.gentoo.org/636934 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--sys-fs/quota/quota-4.04-r1.ebuild8
-rw-r--r--sys-fs/quota/quota-4.04.ebuild79
2 files changed, 3 insertions, 84 deletions
diff --git a/sys-fs/quota/quota-4.04-r1.ebuild b/sys-fs/quota/quota-4.04-r1.ebuild
index 0fccc223e077..b4b4a726d94b 100644
--- a/sys-fs/quota/quota-4.04-r1.ebuild
+++ b/sys-fs/quota/quota-4.04-r1.ebuild
@@ -22,11 +22,9 @@ RDEPEND="
)
rpc? (
net-nds/rpcbind
- || ( sys-libs/glibc[rpc(-)]
- (
- net-libs/rpcsvc-proto
- )
- )
+ elibc_glibc? ( sys-libs/glibc[-rpc(-)] )
+ net-libs/libtirpc
+ net-libs/rpcsvc-proto
)
tcpd? ( sys-apps/tcp-wrappers )
"
diff --git a/sys-fs/quota/quota-4.04.ebuild b/sys-fs/quota/quota-4.04.ebuild
deleted file mode 100644
index d077fb35d664..000000000000
--- a/sys-fs/quota/quota-4.04.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="Linux quota tools"
-HOMEPAGE="https://sourceforge.net/projects/linuxquota/"
-SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="ldap netlink nls rpc tcpd"
-
-RDEPEND="
- ldap? ( >=net-nds/openldap-2.3.35 )
- netlink? (
- sys-apps/dbus
- dev-libs/libnl:3
- )
- rpc? (
- net-nds/rpcbind
- || ( sys-libs/glibc[rpc(-)]
- (
- net-libs/rpcsvc-proto
- )
- )
- )
- tcpd? ( sys-apps/tcp-wrappers )
-"
-DEPEND="
- ${RDEPEND}
- nls? ( sys-devel/gettext )
-"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --docdir="${EPREFIX%/}/usr/share/doc/${PF}"
- $(use_enable nls)
- $(use_enable ldap ldapmail)
- $(use_enable netlink)
- $(use_enable rpc)
- $(use_enable rpc rpcsetquota)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc doc/* README.* Changelog
-
- insinto /etc
- insopts -m0644
- doins warnquota.conf quotatab
-
- newinitd "${FILESDIR}"/quota.rc7 quota
- newconfd "${FILESDIR}"/quota.confd quota
-
- if use rpc ; then
- newinitd "${FILESDIR}"/rpc.rquotad.initd rpc.rquotad
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema
- insopts -m0644
- doins "${FILESDIR}"/ldap-scripts/quota.schema
-
- exeinto /usr/share/quota/ldap-scripts
- doexe "${FILESDIR}"/ldap-scripts/*.pl
- doexe "${FILESDIR}"/ldap-scripts/edquota_editor
- fi
-}