summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-29 17:03:37 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-29 17:04:58 +0200
commitec2b13a11a6b5712817b20dab096a668f4afd06f (patch)
tree75e6269bd6cf2f5693ac721a4e26ab29f63f094d
parentsys-devel/llvm: Pass -Wl,--no-keep-memory to linker on x86 (diff)
downloadgentoo-ec2b13a11a6b5712817b20dab096a668f4afd06f.tar.gz
gentoo-ec2b13a11a6b5712817b20dab096a668f4afd06f.tar.bz2
gentoo-ec2b13a11a6b5712817b20dab096a668f4afd06f.zip
sys-devel/clang: Pass -Wl,--no-keep-memory to linker on x86
Closes: https://bugs.gentoo.org/712052 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/clang/clang-10.0.0.ebuild4
-rw-r--r--sys-devel/clang/clang-10.0.1.9999.ebuild4
-rw-r--r--sys-devel/clang/clang-10.0.1_rc1.ebuild4
-rw-r--r--sys-devel/clang/clang-11.0.0.9999.ebuild4
4 files changed, 16 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-10.0.0.ebuild b/sys-devel/clang/clang-10.0.0.ebuild
index aae5ad123f05..564bc4664b12 100644
--- a/sys-devel/clang/clang-10.0.0.ebuild
+++ b/sys-devel/clang/clang-10.0.0.ebuild
@@ -234,6 +234,10 @@ multilib_src_configure() {
)
fi
+ # LLVM can have very high memory consumption while linking,
+ # exhausting the limit on 32-bit linker executable
+ use x86 && local -x LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory"
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
cmake-utils_src_configure
diff --git a/sys-devel/clang/clang-10.0.1.9999.ebuild b/sys-devel/clang/clang-10.0.1.9999.ebuild
index 2b8d5fee0580..944ffa67b3da 100644
--- a/sys-devel/clang/clang-10.0.1.9999.ebuild
+++ b/sys-devel/clang/clang-10.0.1.9999.ebuild
@@ -289,6 +289,10 @@ multilib_src_configure() {
)
fi
+ # LLVM can have very high memory consumption while linking,
+ # exhausting the limit on 32-bit linker executable
+ use x86 && local -x LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory"
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
cmake_src_configure
diff --git a/sys-devel/clang/clang-10.0.1_rc1.ebuild b/sys-devel/clang/clang-10.0.1_rc1.ebuild
index db3798d217bd..ec2222153574 100644
--- a/sys-devel/clang/clang-10.0.1_rc1.ebuild
+++ b/sys-devel/clang/clang-10.0.1_rc1.ebuild
@@ -289,6 +289,10 @@ multilib_src_configure() {
)
fi
+ # LLVM can have very high memory consumption while linking,
+ # exhausting the limit on 32-bit linker executable
+ use x86 && local -x LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory"
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
cmake_src_configure
diff --git a/sys-devel/clang/clang-11.0.0.9999.ebuild b/sys-devel/clang/clang-11.0.0.9999.ebuild
index 5991c42d4c69..76cb2b8d998e 100644
--- a/sys-devel/clang/clang-11.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-11.0.0.9999.ebuild
@@ -284,6 +284,10 @@ multilib_src_configure() {
)
fi
+ # LLVM can have very high memory consumption while linking,
+ # exhausting the limit on 32-bit linker executable
+ use x86 && local -x LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory"
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
cmake_src_configure