summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-23 08:41:56 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-23 12:02:32 +0200
commiteca85d047cd9072f2c0bda753e488afe897aba04 (patch)
tree4e0d680c7e83bb55ca185ce9b259f5f172d29d4c
parentdev-python/botocore: Bump to 1.19.3 (diff)
downloadgentoo-eca85d047cd9072f2c0bda753e488afe897aba04.tar.gz
gentoo-eca85d047cd9072f2c0bda753e488afe897aba04.tar.bz2
gentoo-eca85d047cd9072f2c0bda753e488afe897aba04.zip
dev-python/boto3: Bump to 1.16.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.16.3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index f0656fd2bde3..51d0df48bd0b 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.15.10.tar.gz 336021 BLAKE2B 71a8bcfd115c0066931e616d1d3678d51ba0946
DIST boto3-1.15.18.tar.gz 336927 BLAKE2B 0ddc7fbd0fffcbeafeee7b9aa0f699087369f315551e243175793c82d95c97dbbe8997d5fc280e9fed18612d1058d858a7b34b0b1b4ac7905774009beb62c0a6 SHA512 2dc88c27bafe7ff2f2b00be94c37e7cabc94f09ca0ccb898a5d29cd8087bb1945d226ed5d87e955250775038fc039740e68d93662b465e99a16cfebfd2fa2944
DIST boto3-1.16.1.tar.gz 337145 BLAKE2B 553b20514d268be967b80cab9694085d8cd3456277d459cf0f92943274eac8cf8fc23b4ed9dc92a9c04f02e3f1f1fd483f71111c9e0cfa22e989098ca5fa762d SHA512 6f8d1848fb89e841054cba6c295b7ccce7fab37ba5312a0b5f87588c8cf9d61124b3988c4565a4b055976ffafdb8ed7fc9268a21ac3160e80ffdf739c8e1609a
DIST boto3-1.16.2.tar.gz 337212 BLAKE2B ebde42cf6b6fec3f00df6cf7e9f8769a2a8295aba0960708d4fb97b0cea4ed68ca5ea698b42485c94dacf0dfbca2fefe12ed878d027eeccee53fdf844afab48e SHA512 305dbbbf5beba3503ae3c4f6ad02ecd7cd55057d19c5c8081dbbb00a620e4a4a1dc55df111e5078ed8172d706f9f868675cd110024d0a8303fba7bf1195cd9cc
+DIST boto3-1.16.3.tar.gz 337217 BLAKE2B f088b596561156823a8caa5b0053688bdac8bdf3f2a54ff0bfd3724fe563493a681c4a16c5a85f990d3edad6c31cb1f0ec7a1fd01deb325a30a1623cc0f1439e SHA512 7bb5ac693a6a0a938c4c83e94cb82dc02fed5edd4709f28961f7123103b38ffb24975c7861d50ebe773fb318f7225442911c8c55b7a621301f270a25f796f104
diff --git a/dev-python/boto3/boto3-1.16.3.ebuild b/dev-python/boto3/boto3-1.16.3.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.16.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}