summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2017-05-24 09:49:10 -0400
committerIan Stakenvicius <axs@gentoo.org>2017-05-24 09:51:19 -0400
commitecb4082e8fa6c452d6bb4572ebd35824fdf4174b (patch)
tree48eb87bf02801111c9d829e4fa483d84dc498592
parentwww-client/firefox-bin: ppc stable wrt bug #616030 (diff)
downloadgentoo-ecb4082e8fa6c452d6bb4572ebd35824fdf4174b.tar.gz
gentoo-ecb4082e8fa6c452d6bb4572ebd35824fdf4174b.tar.bz2
gentoo-ecb4082e8fa6c452d6bb4572ebd35824fdf4174b.zip
x11-plugins/enigmail: bump to 1.9.7
This commit also adds a revbump to 1.9.6-r1 for stable users, the bump contains no changes but its existence will force a reinstall of enigmail that should ensure its contents properly remain on disk. Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--x11-plugins/enigmail/Manifest1
-rw-r--r--x11-plugins/enigmail/enigmail-1.9.6.1-r1.ebuild (renamed from x11-plugins/enigmail/enigmail-1.9.6.1.ebuild)0
-rw-r--r--x11-plugins/enigmail/enigmail-1.9.7.ebuild56
3 files changed, 57 insertions, 0 deletions
diff --git a/x11-plugins/enigmail/Manifest b/x11-plugins/enigmail/Manifest
index b59cef1fdff5..98f91534ea8f 100644
--- a/x11-plugins/enigmail/Manifest
+++ b/x11-plugins/enigmail/Manifest
@@ -1 +1,2 @@
DIST enigmail-1.9.6.1.tar.gz 1745021 SHA256 3874331e981aed864443d3c965d856e003fd84f73e5a89fd5004ced9dc29b96f SHA512 e6ab69734a39a4953e0167e07b06f0d5c83fb42956515392319a1cd9d665ca274f6a12b4141e2dfa373ef074f0526f3d7330a48d29d600fc38f724d26518ff84 WHIRLPOOL e89b0e5857564cc2f7ebf3ab46b110c6bbb1b16e7c0e045750119fd02e693b9bd9667c2932e7a65f9c8fb2c7c835ed048f6df2613d12b25d961894f47f67cf48
+DIST enigmail-1.9.7.tar.gz 1745184 SHA256 176adbafee2f84ef6cd1cdbf53131a2a6a23d0cb26550357617c24a8ae5bd934 SHA512 f6f96f6267f1c9df0ca86fefcf7e0e2b10076f1cdb7d446b2a53710b780c14097ef05ba7f35b83e33aca9f2fca1ca4398c7524c1f5ce6cba39b6733db33eed31 WHIRLPOOL 8816b3404e6b6b3fa4ba3d01f97ba9841b3eb7b1d46d09570b756431b2810f35be26a54ab98769ec051cc0859c761090004ed10886150ec98082db10ba4642f5
diff --git a/x11-plugins/enigmail/enigmail-1.9.6.1.ebuild b/x11-plugins/enigmail/enigmail-1.9.6.1-r1.ebuild
index f10b469ea882..f10b469ea882 100644
--- a/x11-plugins/enigmail/enigmail-1.9.6.1.ebuild
+++ b/x11-plugins/enigmail/enigmail-1.9.6.1-r1.ebuild
diff --git a/x11-plugins/enigmail/enigmail-1.9.7.ebuild b/x11-plugins/enigmail/enigmail-1.9.7.ebuild
new file mode 100644
index 000000000000..ff5e7f5079a3
--- /dev/null
+++ b/x11-plugins/enigmail/enigmail-1.9.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1
+
+DESCRIPTION="Mozilla extension to provide GPG support in mail clients"
+HOMEPAGE="http://www.enigmail.net/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+SLOT="0"
+LICENSE="MPL-2.0 GPL-3"
+IUSE=""
+SRC_URI="http://www.enigmail.net/download/source/${P}.tar.gz"
+
+RDEPEND="|| (
+ ( >=app-crypt/gnupg-2.0
+ || (
+ app-crypt/pinentry[gtk(-)]
+ app-crypt/pinentry[qt4(-)]
+ app-crypt/pinentry[qt5(-)]
+ )
+ )
+ =app-crypt/gnupg-1.4*
+ )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ app-arch/zip
+ dev-lang/perl
+ "
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake ipc public ui package lang
+ emake xpi
+
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r build/dist/{chrome,components,defaults,modules,wrappers,chrome.manifest,install.rdf}
+}
+
+pkg_postinst() {
+ local peimpl=$(eselect --brief --colour=no pinentry show)
+ case "${peimpl}" in
+ *gtk*|*qt*) ;;
+ *) ewarn "The pinentry front-end currently selected is not one supported by thunderbird."
+ ewarn "You may be prompted for your password in an inaccessible shell!!"
+ ewarn "Please use 'eselect pinentry' to select either the gtk or qt front-end"
+ ;;
+ esac
+}