summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-02-22 22:08:28 +1300
committerKent Fredric <kentfredric@gmail.com>2016-02-27 21:39:56 +1300
commited0bd91f0cf1ab0dbd1544a6c5a4f6e7dc24b8d3 (patch)
treeeb8ab13d49a52acb9440754dcb18cdc86bd7ca3e
parentdev-perl/Encode-EUCJPASCII: Remove old version (diff)
downloadgentoo-ed0bd91f0cf1ab0dbd1544a6c5a4f6e7dc24b8d3.tar.gz
gentoo-ed0bd91f0cf1ab0dbd1544a6c5a4f6e7dc24b8d3.tar.bz2
gentoo-ed0bd91f0cf1ab0dbd1544a6c5a4f6e7dc24b8d3.zip
dev-perl/MIME-Charset: Bump to 1.12.0
- use EAPI6 - Add LINGUAS="ja zh" as these are features exported by Makefile.PL by default, and can be tripped into if people use a corresponding encoding entry in https://metacpan.org/source/NEZUMI/MIME-Charset-1.012/lib/MIME/Charset.pm#L223 - Drop x86 and ppc due to dev-perl/Encode-{EUCJPASCII,HanExtra} - Potential explosions with CPAN + Module::AutoInstall nuked with Makefile.PL patch Package-Manager: portage-2.2.27
-rw-r--r--dev-perl/MIME-Charset/MIME-Charset-1.12.0.ebuild28
-rw-r--r--dev-perl/MIME-Charset/Manifest1
-rw-r--r--dev-perl/MIME-Charset/files/1.012-makefilepl.patch18
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-perl/MIME-Charset/MIME-Charset-1.12.0.ebuild b/dev-perl/MIME-Charset/MIME-Charset-1.12.0.ebuild
new file mode 100644
index 000000000000..dbdfdcf8b4a9
--- /dev/null
+++ b/dev-perl/MIME-Charset/MIME-Charset-1.12.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=NEZUMI
+DIST_VERSION=1.012
+inherit perl-module
+
+DESCRIPTION="Charset Informations for MIME"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="linguas_ja linguas_zh"
+PATCHES=(
+ "${FILESDIR}/${DIST_VERSION}-makefilepl.patch"
+)
+# Put JISX0213 here one day
+# And POD2
+RDEPEND="
+ >=virtual/perl-Encode-1.980.0
+ linguas_ja? ( >=dev-perl/Encode-EUCJPASCII-0.20.0 )
+ linguas_zh? ( >=dev-perl/Encode-HanExtra-0.200.0 )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
diff --git a/dev-perl/MIME-Charset/Manifest b/dev-perl/MIME-Charset/Manifest
index b9513fd722ff..f1cbf3cdfd20 100644
--- a/dev-perl/MIME-Charset/Manifest
+++ b/dev-perl/MIME-Charset/Manifest
@@ -1 +1,2 @@
DIST MIME-Charset-1.009.3.tar.gz 50401 SHA256 57078ab83a8e8d8ae3e64ae4f7f80fc4b885520ca4b7b52833073506ab7ba48d SHA512 cc6780145482aec0b61e83b002b7939d2a592eaf4a893e0101a9dd78ba9e548914e854330a51d4d5bea267d67028653c790c221997c7939b0a9d75ba642d615c WHIRLPOOL 39ab469fb22a2c8927d95f68e55d86c9ac01acee1174bb285e6d361212d0a622c54cb2e4ecb09ce5889c0f0a48fd141a6e693effcc0cc6420e1ed01c1790793c
+DIST MIME-Charset-1.012.tar.gz 55201 SHA256 cee5d1d4184ad46ca17d995335bc8d9b6d95e1e64584079d032cf5f0c82dcccd SHA512 f116deb04912bdccfd98484ef82d643d23b4cb90bfdf88ddc60d0a3f857ac3f084a60681a6fae4f9a2d982d6f470c79f171688e44a4034e9533bb518a914e2fe WHIRLPOOL a7bd7be1d927d2274e0834feb82ece5df514937b1beef557d70bb857bb208015e580e0ae71eb9467aa27e865c8606041cd28446d541bdec60c469ffa6b950d63
diff --git a/dev-perl/MIME-Charset/files/1.012-makefilepl.patch b/dev-perl/MIME-Charset/files/1.012-makefilepl.patch
new file mode 100644
index 000000000000..1552dccd5093
--- /dev/null
+++ b/dev-perl/MIME-Charset/files/1.012-makefilepl.patch
@@ -0,0 +1,18 @@
+diff -Naur MIME-Charset-1.012/Makefile.PL MIME-Charset-1.012.new/Makefile.PL
+--- MIME-Charset-1.012/Makefile.PL 2013-10-30 03:03:10.000000000 +0000
++++ MIME-Charset-1.012.new/Makefile.PL 2016-02-22 08:25:19.069712121 +0000
+@@ -8,7 +8,6 @@
+ check_nmake;
+
+ # Specific dependencies
+-configure_requires 'CPAN' => 0; # for inc::Module::AutoInstall
+ test_requires 'Test::More' => '0';
+ if ( $] >= 5.007003 ) {
+ requires 'Encode' => '1.98';
+@@ -29,6 +28,5 @@
+
+ # Write out
+ no_index directory => 't', 'inc';
+-auto_install force => 0, do_once => 1;
+ WriteAll;
+