summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-09-20 14:37:23 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2015-09-20 19:50:11 +0100
commitf0b811994bca42b776cd31c253d93acbac677f5b (patch)
treedc69535e0a5913a867a7c4b70afe2d0781fbf115
parentdev-haskell/encoding: amd64 x86 stable, bug #524790 (diff)
downloadgentoo-f0b811994bca42b776cd31c253d93acbac677f5b.tar.gz
gentoo-f0b811994bca42b776cd31c253d93acbac677f5b.tar.bz2
gentoo-f0b811994bca42b776cd31c253d93acbac677f5b.zip
dev-haskell/mtl-compat: Backported Control.Monad.Except module from dev-haskell/mtl-2.2.
Package-Manager: portage-2.2.20
-rw-r--r--dev-haskell/mtl-compat/Manifest1
-rw-r--r--dev-haskell/mtl-compat/metadata.xml22
-rw-r--r--dev-haskell/mtl-compat/mtl-compat-0.2.1.3.ebuild27
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-haskell/mtl-compat/Manifest b/dev-haskell/mtl-compat/Manifest
new file mode 100644
index 000000000000..1e8f3730b057
--- /dev/null
+++ b/dev-haskell/mtl-compat/Manifest
@@ -0,0 +1 @@
+DIST mtl-compat-0.2.1.3.tar.gz 4584 SHA256 6458ca53593a31ebce1d94ef8dd4f6a06d050dd7ed32335f6cc6b6e5d3456894 SHA512 c9afa97eb5dc1bddcbf0e088352141d56b603562f80fcbde6811610a4e71e1496dd5f07e4338644930bf06b403bc08d35799f7063ae845ecdb71e619b2342a18 WHIRLPOOL 6e5e43a18983734c4586bc29bb49423536b82f72b9bb2b7246610f9b4e7820d342513b5497d17048ed56ec301ecc8145e7672afaf3bdd27dd788a705bfb2d6cf
diff --git a/dev-haskell/mtl-compat/metadata.xml b/dev-haskell/mtl-compat/metadata.xml
new file mode 100644
index 000000000000..95fbdda5c946
--- /dev/null
+++ b/dev-haskell/mtl-compat/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This package backports the &quot;Control.Monad.Except&quot; module from
+ @mtl@ (if using @mtl-2.2.0.1@ or earlier), which reexports the
+ @ExceptT@ monad transformer and the @MonadError@ class.
+
+ This package should only be used if there is a need to use the
+ @Control.Monad.Except@ module specifically. If you just want
+ the @mtl@ class instances for @ExceptT@, use
+ @transformers-compat@ instead, since @mtl-compat@ does nothing
+ but reexport the instances from that package.
+
+ Note that unlike how @mtl-2.2@ or later works, the
+ &quot;Control.Monad.Except&quot; module defined in this package exports
+ all of @ExceptT@&#39;s monad class instances. Therefore, you may
+ have to declare @import Control.Monad.Except ()@ at the top of
+ your file to get all of the @ExceptT@ instances in scope.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/mtl-compat/mtl-compat-0.2.1.3.ebuild b/dev-haskell/mtl-compat/mtl-compat-0.2.1.3.ebuild
new file mode 100644
index 000000000000..0b90407a6947
--- /dev/null
+++ b/dev-haskell/mtl-compat/mtl-compat-0.2.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5
+
+CABAL_FEATURES="lib profile" # haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Backported Control.Monad.Except module from mtl"
+HOMEPAGE="https://github.com/RyanGlScott/mtl-compat"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ dev-haskell/transformers-compat:=
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"