summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikos Chantziaras <realnc@gmail.com>2018-03-26 18:36:23 +0300
committerJames Le Cuirot <chewi@gentoo.org>2018-03-26 21:59:43 +0100
commitf10514362218c557f2cb0aff2c1790094c8ae655 (patch)
treeaa555366ed9c0d54f5e96809b4e2a3e6db08308d
parentapp-accessibility/powiedz: EAPI bump and patch cleanup (diff)
downloadgentoo-f10514362218c557f2cb0aff2c1790094c8ae655.tar.gz
gentoo-f10514362218c557f2cb0aff2c1790094c8ae655.tar.bz2
gentoo-f10514362218c557f2cb0aff2c1790094c8ae655.zip
dev-util/patchelf: git snapshot version bump to 0.9_p20180129
Current (0.9) version of patchelf fails to update the .gnu.version_r section of binary executables when patching them, resulting in the executable being unable to run: $ patchelf --replace-needed "libcurl-gnutls.so.4" "libcurl.so.4" my_binary $ ./my_binary Inconsistency detected by ld.so: dl-version.c: 224: _dl_check_map_versions: Assertion `needed != ((void *)0)' failed! This has been fixed by upstream a couple years ago, but patchelf has not done a new release since then. This version bump grabs a Git snapshot. Closes: https://bugs.gentoo.org/651600 Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7625
-rw-r--r--dev-util/patchelf/Manifest1
-rw-r--r--dev-util/patchelf/patchelf-0.9_p20180129.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/patchelf/Manifest b/dev-util/patchelf/Manifest
index 9c4a653bc3e5..c05694b07e29 100644
--- a/dev-util/patchelf/Manifest
+++ b/dev-util/patchelf/Manifest
@@ -1,2 +1,3 @@
DIST patchelf-0.8.tar.bz2 119369 BLAKE2B bfe7dceea9a79845c61bc7490faad5cd4d5e83bc0be4ec7e3b19fbed91ecb7d15e0a0688d4914731b94f0522c80ea9f940b6a8ad5595931df8826ef43f2fd209 SHA512 819ace0ee032612e8bef56f230ea470be9d44bc03ef561f98ffac84f2555e419f87309280df6d265a8ae56452e54d46fc90be13a449847e93e4e7b413dc8605a
DIST patchelf-0.9.tar.bz2 159956 BLAKE2B 7e8543a98aa683eeafacfb836a02ad7cf2fb52409b0780edb614e30edc66f8f356a9bd19e133b185861fe9c6ae0e4868b0b307c174610eef80e3446610f76bcb SHA512 5bd3a1268b809f173debde5d34c3f736f38d7afb69decf609a422884c51eb1d5ccf62f2d454d4ef8b2c20e263ece49e3c2f801347ef1dfcceecd89c78a214790
+DIST patchelf-0.9_p20180129.tar.gz 99490 BLAKE2B a5372942f7f400085a1d5e15701a25f916012ae6afc90cc3065aebf6fd0fc7cae3a626496cae4a7ce7320e5c954b0b11a14defae0bacf3350bf6b201db952eb5 SHA512 eabeb34dbef68dc6e79374f46bdbe473ca3c21515962c684f3368fdf7a1dbea75ec152fdb7796f9d22c2f40da25e3f9c181cd1a29e52fbe5843a8cd02acb2c75
diff --git a/dev-util/patchelf/patchelf-0.9_p20180129.ebuild b/dev-util/patchelf/patchelf-0.9_p20180129.ebuild
new file mode 100644
index 000000000000..0efbab73c0ab
--- /dev/null
+++ b/dev-util/patchelf/patchelf-0.9_p20180129.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools vcs-snapshot
+
+DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
+HOMEPAGE="http://nixos.org/patchelf.html"
+COMMIT=1fa4d36fead44333528cbee4b5c04c207ce77ca4
+SRC_URI="https://github.com/NixOS/${PN^}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+
+src_prepare() {
+ default
+ rm src/elf.h || die
+
+ sed -i \
+ -e 's:-Werror::g' \
+ -e 's:parallel-tests:serial-tests:g' \
+ configure.ac || die
+
+ eautoreconf
+}