summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-07-31 22:14:01 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-07-31 22:14:01 +0100
commitf25356875b71b2a5c56abfbca0cca0651fd83c6c (patch)
tree3508a7c34aa2e5029c26a1c3985fd5ef1d536308
parentwww-servers/nginx: rev bump to bump 3rd party modules (diff)
downloadgentoo-f25356875b71b2a5c56abfbca0cca0651fd83c6c.tar.gz
gentoo-f25356875b71b2a5c56abfbca0cca0651fd83c6c.tar.bz2
gentoo-f25356875b71b2a5c56abfbca0cca0651fd83c6c.zip
sys-devel/crossdev: bump up to 20180731
Closes: https://bugs.gentoo.org/631492 Package-Manager: Portage-2.3.44, Repoman-2.3.10
-rw-r--r--sys-devel/crossdev/Manifest1
-rw-r--r--sys-devel/crossdev/crossdev-20180731.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index 9c4df997cfc5..7cf182e99bc9 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -1,3 +1,4 @@
DIST crossdev-20171230.tar.xz 23016 BLAKE2B 4661b3f9fac314b7346f0de7227d12ae2d6851e448f6d065471499df8ada5d699ef91c6b6bca285b2aefcbf67ab351fefbe9344c0884a7c0d33ff27215c8ed9c SHA512 bf8761a3018790501adb4bb173e3281d1d7628de8f65a1aa5df0b328a4af8088be466dbe8c185e7ed44aca31b078320a4f62c56351f4b7cbf832349184d9709f
DIST crossdev-20180410.tar.xz 26716 BLAKE2B 67f47052af4299028470613900e7f1b91fd2b861cce71d2a4b40bb1bf16a7b9b8967eed18dabcca819d89cfb30cbf1253498b2ef9eab8d941a6d611d333b6d65 SHA512 2e70f8c01e7b1484e76dee82fb3342cbcbd60ee3458e2c6acf5b642e01be95546fe03fc00c82d59fa871aae9f5a6728f45f9f7cb4bc27c4cdf56c4fd8a93b754
DIST crossdev-20180508.tar.xz 26728 BLAKE2B ab92cac544ee787ca91c794191c51faeab99e88bc2fc695c5e913e4137cc941457f5b27bf22f3b6a7991fa46ebdc2e5b4238a01425c5021fa9fc05ca23c51f49 SHA512 a96afeeb03747ce67a39b53b925361d07117b49316b5c657413125413d006de25249b0d3d1804c8a946c288c80beb42aa7c32362b57ac81399d26a67ceccfe04
+DIST crossdev-20180731.tar.xz 26808 BLAKE2B eea12e6405546ca5a8409a853afdcbb25f3f2a7336c428b7c6a5d38b29d772989da7c0a59ce282ee925a9126e396bead17798a25bff1b5019a28ba0ef3bc55fc SHA512 245144b57242b7ae1bca65f457bfb60ec4fe1a4cb5f332dc5ac42d14740dda49e7e5266b10e60bebc84be7fabbac827335fcbc8e0dd74e24f423ddfef33edb7e
diff --git a/sys-devel/crossdev/crossdev-20180731.ebuild b/sys-devel/crossdev/crossdev-20180731.ebuild
new file mode 100644
index 000000000000..d1adb4564b57
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20180731.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ || (
+ >=sys-apps/portage-2.1
+ sys-apps/portage-mgorny
+ )
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ sys-apps/gentoo-functions
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED%/}"/usr/bin/crossdev || die
+ fi
+}