summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-06-16 06:51:28 -0700
committerMatt Turner <mattst88@gentoo.org>2017-06-16 07:02:22 -0700
commitf299c787bacbbf389046613d7c94f5bbb8e7d98a (patch)
tree4370cd888b6ef8aabee686a8c301ddd56c935331
parentwww-client/google-chrome-unstable: automated update (61.0.3128.3) (diff)
downloadgentoo-f299c787bacbbf389046613d7c94f5bbb8e7d98a.tar.gz
gentoo-f299c787bacbbf389046613d7c94f5bbb8e7d98a.tar.bz2
gentoo-f299c787bacbbf389046613d7c94f5bbb8e7d98a.zip
sys-apps/cpuid: Version bump to 20170122
Bug: https://bugs.gentoo.org/611924
-rw-r--r--sys-apps/cpuid/Manifest1
-rw-r--r--sys-apps/cpuid/cpuid-20170122.ebuild30
-rw-r--r--sys-apps/cpuid/files/cpuid-20170122-Makefile.patch28
3 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/cpuid/Manifest b/sys-apps/cpuid/Manifest
index 33784bca9dd7..885ca13845aa 100644
--- a/sys-apps/cpuid/Manifest
+++ b/sys-apps/cpuid/Manifest
@@ -2,3 +2,4 @@ DIST cpuid-20130610.src.tar.gz 65801 SHA256 f87e835a83e69013eee09eded0e9c5ac0ea5
DIST cpuid-20140123.src.tar.gz 67882 SHA256 b85aba5696d382f0dba8dc246bd42d09767089d6181a9cd0633d626f079d79ff SHA512 8b205cc539959dcd63326d5de700e090213f5b7cdbd5e25925b8db774001cbd95df7ccb696fda124226380fef69ea7fe0c0885869b0ec7e07b0c340dc0cd8a5b WHIRLPOOL dfcc1b6ea125fb0b6c13b7edd7f6c37592a2acfbc178f4c65cd7ec1577010ec9cc69919af512681e4af048ab028cb8992d1a282435e5b4aace179c40ff607ac4
DIST cpuid-20150606.src.tar.gz 71882 SHA256 b7607e81e62e4901180d9e2f48fe407033211c3fb300d758a210f746ef518c4e SHA512 6f99266b9720b48ec10f220f8a321d3ed052300960151feb6c45d39b586216745f070241db20afd4d16ac0b3389b634eb31f90c93ea9d12f521012cfe5ab9257 WHIRLPOOL 0c7140b636e7cca8ac0d150cb015170964471a3e00d48f3b7290976c768415773d5741f53937b2773b751a8e830d21e156c3f199de081dd42c50ffd76688e640
DIST cpuid-20151017.src.tar.gz 72787 SHA256 34d35ddd7dab7c9f8b071b7b318d4f99fe112caaa28b6c8571e2ecdaa855db78 SHA512 83e6d49bd043e3f21610e50e5ca98705ee78bb1527f90e184f8aa380bfce82dc4168f5ef7b85e1e337e059668f4c83b20b96578f303bf73383b0241a50cd5296 WHIRLPOOL a28f12a7b403611d0ea0e6d8e08d27be424b2194a7818a5281a37a19d6b412938fb57b4d067461fc754fe469d536b0f009282e14ce619228326aefd6d6f8b892
+DIST cpuid-20170122.src.tar.gz 80046 SHA256 667612aae6704341dd10844e97c84c5c5c8700817a5937a3c293b55013bc4865 SHA512 0e057980c71a0e078254e6b7535747bdf368278932c39943cf7dfafe08443af07297a2b41518499937a710fe6950ba89377cabaada5f6332932650d4d17c1430 WHIRLPOOL 25594a2629c8da251d9cbc511a726cf2a4a235cc361c002fd6fa127c9d589f08938475094ea366861bb83b070d5d5955eac494d2b17958e2204b3e7275fd287c
diff --git a/sys-apps/cpuid/cpuid-20170122.ebuild b/sys-apps/cpuid/cpuid-20170122.ebuild
new file mode 100644
index 000000000000..3c76118816bc
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20170122.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to get detailed information about the CPU(s) using the
+CPUID instruction"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-20170122-Makefile.patch
+ eapply_user
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake BUILDROOT="${D}" install || die "email install failed"
+}
diff --git a/sys-apps/cpuid/files/cpuid-20170122-Makefile.patch b/sys-apps/cpuid/files/cpuid-20170122-Makefile.patch
new file mode 100644
index 000000000000..9a02a54563aa
--- /dev/null
+++ b/sys-apps/cpuid/files/cpuid-20170122-Makefile.patch
@@ -0,0 +1,28 @@
+diff -ru cpuid-20170122.orig/Makefile cpuid-20170122/Makefile
+--- cpuid-20170122.orig/Makefile 2017-06-16 06:54:32.993875817 -0700
++++ cpuid-20170122/Makefile 2017-06-16 06:55:56.622875498 -0700
+@@ -1,9 +1,3 @@
+-CFLAGS+=-g
+-CPPFLAGS?=
+-LDFLAGS?=
+-ifneq (,$(findstring arch=i386,$(CFLAGS)))
+-CISA=-m32
+-endif
+ CFL=$(CPPFLAGS) $(CFLAGS) $(CISA) -Wall -Wshadow -Wcast-align -Wredundant-decls -Wbad-function-cast -Wcast-qual -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -D_FILE_OFFSET_BITS=64 -DVERSION=$(VERSION)
+
+ PACKAGE=cpuid
+@@ -51,10 +45,10 @@
+ gzip < $< > $@
+
+ install: $(PROG) $(PROG).man.gz cpuinfo2cpuid cpuinfo2cpuid.man.gz
+- install -D -s -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
+- install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
+- install -D -m 755 cpuinfo2cpuid $(BUILDROOT)/usr/bin/cpuinfo2cpuid
+- install -D -m 444 cpuinfo2cpuid.man.gz $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1.gz
++ install -D -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
++ install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
++ install -D -m 755 cpuinfo2cpuid $(BUILDROOT)/usr/bin/cpuinfo2cpuid
++ install -D -m 444 cpuinfo2cpuid.man.gz $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1.gz
+
+ clean:
+ rm -f $(PROG) $(PROG).i386 $(PROG).x86_64