summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-29 18:31:31 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-29 18:31:31 +0200
commitf325ef8d53d8dd6a3fe12b168e5b7bef88984a3b (patch)
tree8b9432d87bd416a5b74473f1e0a217dd01d9a242
parentnet-misc/linux-eoip: Port to EAPI 7 (diff)
downloadgentoo-f325ef8d53d8dd6a3fe12b168e5b7bef88984a3b.tar.gz
gentoo-f325ef8d53d8dd6a3fe12b168e5b7bef88984a3b.tar.bz2
gentoo-f325ef8d53d8dd6a3fe12b168e5b7bef88984a3b.zip
app-i18n/scim-pinyin: Port to EAPI 7
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-i18n/scim-pinyin/scim-pinyin-0.5.92.ebuild42
1 files changed, 25 insertions, 17 deletions
diff --git a/app-i18n/scim-pinyin/scim-pinyin-0.5.92.ebuild b/app-i18n/scim-pinyin/scim-pinyin-0.5.92.ebuild
index b0faa6aeb726..48730fbcfdc4 100644
--- a/app-i18n/scim-pinyin/scim-pinyin-0.5.92.ebuild
+++ b/app-i18n/scim-pinyin/scim-pinyin-0.5.92.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit autotools-utils
+inherit autotools
DESCRIPTION="Smart Common Input Method (SCIM) Smart Pinyin Input Method"
HOMEPAGE="http://www.scim-im.org/"
@@ -14,25 +14,33 @@ SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86"
IUSE="nls"
-RDEPEND="x11-libs/libXt
+RDEPEND="
>=app-i18n/scim-1.1
+ x11-libs/libXt
nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
nls? ( sys-devel/gettext )"
-AUTOTOOLS_AUTORECONF=1
-PATCHES=(
- "${FILESDIR}/${PN}-0.5.91-fixconfigure.patch"
-)
-DOCS=( AUTHORS NEWS README ChangeLog )
+
+PATCHES=( "${FILESDIR}"/${PN}-0.5.91-fixconfigure.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
- local myeconfargs=(
+ econf \
+ --disable-skim-support \
+ --disable-static \
+ --without-arts \
$(use_enable nls)
- --disable-skim-support
- --without-arts
- --disable-static
- --disable-depedency-tracking
- )
- autotools-utils_src_configure
+}
+
+src_install() {
+ default
+
+ # only plugins
+ find "${ED}" -name '*.la' -delete || die
}