summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-11-15 12:14:43 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-11-15 12:15:01 +0100
commitf58ab45eda5018e13a83c2ff5c4beacd8248a91e (patch)
treec5f635de740b860b4550ceaefd510da74a99a368
parentapp-emulation/xen-pvgrub: version bump 4.6.4 (diff)
downloadgentoo-f58ab45eda5018e13a83c2ff5c4beacd8248a91e.tar.gz
gentoo-f58ab45eda5018e13a83c2ff5c4beacd8248a91e.tar.bz2
gentoo-f58ab45eda5018e13a83c2ff5c4beacd8248a91e.zip
app-emulation/docker: Add support for container init system
Package-Manager: portage-2.3.2
-rw-r--r--app-emulation/docker/docker-1.13.0_rc1.ebuild4
-rw-r--r--app-emulation/docker/docker-9999.ebuild4
-rw-r--r--app-emulation/docker/metadata.xml4
3 files changed, 10 insertions, 2 deletions
diff --git a/app-emulation/docker/docker-1.13.0_rc1.ebuild b/app-emulation/docker/docker-1.13.0_rc1.ebuild
index 32e517ec0d0c..85caf5fa6fec 100644
--- a/app-emulation/docker/docker-1.13.0_rc1.ebuild
+++ b/app-emulation/docker/docker-1.13.0_rc1.ebuild
@@ -26,7 +26,7 @@ DESCRIPTION="The core functions you need to create Docker images and run Docker
HOMEPAGE="https://dockerproject.org"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="apparmor aufs btrfs +device-mapper hardened overlay pkcs11 seccomp"
+IUSE="apparmor aufs btrfs +container-init +device-mapper hardened overlay pkcs11 seccomp"
# https://github.com/docker/docker/blob/master/project/PACKAGERS.md#build-dependencies
CDEPEND="
@@ -62,6 +62,7 @@ RDEPEND="
>app-emulation/containerd-0.2.2
app-emulation/runc[apparmor?,seccomp?]
app-emulation/docker-proxy
+ container-init? ( >=sys-process/tini-0.13.0[static] )
"
RESTRICT="installsources strip"
@@ -243,6 +244,7 @@ src_install() {
dosym containerd /usr/bin/docker-containerd
dosym containerd-shim /usr/bin/docker-containerd-shim
dosym runc /usr/bin/docker-runc
+ use container-init && dosym tini-static /usr/bin/docker-init
newinitd contrib/init/openrc/docker.initd docker
newconfd contrib/init/openrc/docker.confd docker
diff --git a/app-emulation/docker/docker-9999.ebuild b/app-emulation/docker/docker-9999.ebuild
index f7e5a3337072..aaa79c9615b2 100644
--- a/app-emulation/docker/docker-9999.ebuild
+++ b/app-emulation/docker/docker-9999.ebuild
@@ -26,7 +26,7 @@ DESCRIPTION="The core functions you need to create Docker images and run Docker
HOMEPAGE="https://dockerproject.org"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="apparmor aufs btrfs +device-mapper hardened overlay pkcs11 seccomp"
+IUSE="apparmor aufs btrfs +container-init +device-mapper hardened overlay pkcs11 seccomp"
# https://github.com/docker/docker/blob/master/project/PACKAGERS.md#build-dependencies
CDEPEND="
@@ -62,6 +62,7 @@ RDEPEND="
>app-emulation/containerd-0.2.2
app-emulation/runc[apparmor?,seccomp?]
app-emulation/docker-proxy
+ container-init? ( >=sys-process/tini-0.13.0[static] )
"
RESTRICT="installsources strip"
@@ -243,6 +244,7 @@ src_install() {
dosym containerd /usr/bin/docker-containerd
dosym containerd-shim /usr/bin/docker-containerd-shim
dosym runc /usr/bin/docker-runc
+ use container-init && dosym tini-static /usr/bin/docker-init
newinitd contrib/init/openrc/docker.initd docker
newconfd contrib/init/openrc/docker.confd docker
diff --git a/app-emulation/docker/metadata.xml b/app-emulation/docker/metadata.xml
index dbf678fa73dc..1299d4143fd3 100644
--- a/app-emulation/docker/metadata.xml
+++ b/app-emulation/docker/metadata.xml
@@ -36,6 +36,10 @@
Enables dependencies for the "btrfs" graph driver, including
necessary kernel flags.
</flag>
+ <flag name="container-init">
+ Makes the a staticly-linked init system tini available inside a
+ container.
+ </flag>
<flag name="device-mapper">
Enables dependencies for the "devicemapper" graph driver, including
necessary kernel flags.