summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-09-15 21:10:18 +0200
committerTupone Alfredo <tupone@gentoo.org>2019-09-15 21:10:18 +0200
commitf634ca7de8f95c9fda23e6a1fc364f00148b0d5a (patch)
tree8c1c91b80770c27b407227ab3908c46d2a7c5d9d
parentdev-libs/expat: arm64 stable (bug #694362) (diff)
downloadgentoo-f634ca7de8f95c9fda23e6a1fc364f00148b0d5a.tar.gz
gentoo-f634ca7de8f95c9fda23e6a1fc364f00148b0d5a.tar.bz2
gentoo-f634ca7de8f95c9fda23e6a1fc364f00148b0d5a.zip
dev-ada/gnatcoll-core: simplify using ada eclass
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ada/gnatcoll-core/gnatcoll-core-2019-r1.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/dev-ada/gnatcoll-core/gnatcoll-core-2019-r1.ebuild b/dev-ada/gnatcoll-core/gnatcoll-core-2019-r1.ebuild
new file mode 100644
index 000000000000..cb9b5560caeb
--- /dev/null
+++ b/dev-ada/gnatcoll-core/gnatcoll-core-2019-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ADA_COMPAT=( gnat_201{6,7,8,9} )
+inherit ada multiprocessing
+
+MYP=${P}-20190515-24AD8
+
+DESCRIPTION="GNAT Component Collection Core packages"
+HOMEPAGE="http://libre.adacore.com"
+SRC_URI="http://mirrors.cdn.adacore.com/art/5cdf8ae231e87a8f1d425052
+ -> ${MYP}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnat_2019 +shared static-libs static-pic"
+
+RDEPEND="
+ dev-ada/libgpr[${ADA_USEDEP},shared?,static-libs?,static-pic?]
+ !dev-ada/gnatcoll"
+DEPEND="${RDEPEND}
+ dev-ada/gprbuild[${ADA_USEDEP}]"
+
+REQUIRED_USE="${ADA_REQUIRED_USE}"
+
+S="${WORKDIR}"/${MYP}-src
+
+PATCHES=( "${FILESDIR}"/${PN}-2018-gentoo.patch )
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:@GNATLS@:${GNATLS}:g" \
+ src/gnatcoll-projects.ads \
+ || die
+}
+
+src_configure() {
+ emake prefix="${D}"/usr PROCESSORS=$(makeopts_jobs) setup
+}
+
+src_compile() {
+ build () {
+ gprbuild -p -m -j$(makeopts_jobs) \
+ -XBUILD=PROD -v -XGNATCOLL_VERSION=${PV} \
+ -XLIBRARY_TYPE=$1 -XXMLADA_BUILD=$* -XGPR_BUILD=$1 \
+ gnatcoll.gpr -cargs:C ${CFLAGS} -cargs:Ada ${ADAFLAGS} || die
+ }
+ if use shared; then
+ build relocatable
+ fi
+ if use static-pic; then
+ build static-pic
+ fi
+ if use static-libs; then
+ build static
+ fi
+}
+
+src_install() {
+ if use shared; then
+ emake install-relocatable
+ fi
+ if use static-pic; then
+ emake install-static-pic
+ fi
+ if use static-libs; then
+ emake install-static
+ fi
+ rm -r "${D}"/usr/share/gpr/manifests || die
+ einstalldocs
+}