summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-12 13:39:49 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-12 13:40:15 +0200
commitf661362f60a3734991fe0c24ad9b775626982a01 (patch)
tree83b411ddb3899f257040b7c6e810f62739f67af1
parentdev-python/openpyxl: Version Bump (diff)
downloadgentoo-f661362f60a3734991fe0c24ad9b775626982a01.tar.gz
gentoo-f661362f60a3734991fe0c24ad9b775626982a01.tar.bz2
gentoo-f661362f60a3734991fe0c24ad9b775626982a01.zip
sci-chemistry/relax: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sci-chemistry/relax/Manifest1
-rw-r--r--sci-chemistry/relax/relax-3.3.9.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sci-chemistry/relax/Manifest b/sci-chemistry/relax/Manifest
index 30af534e0874..42f7f7f33e2b 100644
--- a/sci-chemistry/relax/Manifest
+++ b/sci-chemistry/relax/Manifest
@@ -1 +1,2 @@
DIST relax-3.3.8.src.tar.bz2 90271667 SHA256 176d4e9f0f1c6cf6e6c93b12070a50ff31e10c8dbe2c05cfc2b253e51425b12d SHA512 ddc9df4a8da4ec563403003ae5bc9ecdf5f3bb7341e2306c405fcf7953ab67cab93e9f64139465b05acfa2c842da1624d941b481ef77c20804cabe7c9df811f9 WHIRLPOOL 1a7f77fc9cd712b7ca459a1943dffde4e154fa2d5e06b77ec42568b012c4319dd43eb0b85cdfd6116b9ba2584e5bd58e1b0d8ea8524d462ab4e18e33d4fa315e
+DIST relax-3.3.9.src.tar.bz2 93403953 SHA256 5bfa0fc774cfafd30e9f593f6b5f368b6bd79faf0ca2e7ae064a8bd3b6923685 SHA512 0af93497acd91e6e4be0cf07efe09198c1234e70641835668a94714d58ad225d5ef94df3225d4d6809aa456e340c05829520f4aa6215cb83f7315ccca2053461 WHIRLPOOL 4ea5bb6582a020df902b9ac28cf5e025456607ddb50b1a6c1915db421ac6ea415781cb9d361fd34b2240500e7d0b74af131984dddcea6b0548dfb76d8b2be378
diff --git a/sci-chemistry/relax/relax-3.3.9.ebuild b/sci-chemistry/relax/relax-3.3.9.ebuild
new file mode 100644
index 000000000000..5ffdf922756d
--- /dev/null
+++ b/sci-chemistry/relax/relax-3.3.9.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+WX_GTK_VER="2.9"
+
+inherit eutils multiprocessing python-single-r1 scons-utils toolchain-funcs wxwidgets virtualx
+
+DESCRIPTION="Molecular dynamics by NMR data analysis"
+HOMEPAGE="http://www.nmr-relax.com/"
+SRC_URI="http://download.gna.org/relax/${P}.src.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/Numdifftools[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/wxpython:${WX_GTK_VER}[${PYTHON_USEDEP}]
+ sci-chemistry/molmol
+ sci-chemistry/pymol[${PYTHON_USEDEP}]
+ sci-chemistry/vmd
+ >=sci-libs/bmrblib-1.0.3[${PYTHON_USEDEP}]
+ >=sci-libs/minfx-1.0.11[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-visualization/grace
+ sci-visualization/opendx
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="${RDEPEND}
+ media-gfx/pngcrush
+ test? ( ${RDEPEND} )
+ "
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ rm -rf minfx bmrblib extern/numdifftools || die
+ tc-export CC
+}
+
+src_compile() {
+ escons
+}
+
+src_test() {
+ VIRTUALX_COMMAND="${EPYTHON} ./${PN}.py -x --traceback"
+ virtualmake
+}
+
+src_install() {
+ dodoc README docs/{CHANGES,COMMITTERS,JOBS,relax.pdf}
+
+ python_moduleinto ${PN}
+ python_domodule *
+
+ rm ${PN} README || die
+
+ make_wrapper ${PN}-nmr "${EPYTHON} $(python_get_sitedir)/${PN}/${PN}.py $@"
+}