summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-12-04 08:22:17 +0100
committerJeroen Roovers <jer@gentoo.org>2018-12-04 10:16:51 +0100
commitf7ebf1b355a719c466cce4a54c674416a6c5b6e5 (patch)
treea37ffaa2d10b1da4d76b4919aeed457f675f5264
parentdev-util/radare2: refetch upstream tarball, bug #672480 (diff)
downloadgentoo-f7ebf1b355a719c466cce4a54c674416a6c5b6e5.tar.gz
gentoo-f7ebf1b355a719c466cce4a54c674416a6c5b6e5.tar.bz2
gentoo-f7ebf1b355a719c466cce4a54c674416a6c5b6e5.zip
dev-util/debootstrap: Version 1.0.111
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--dev-util/debootstrap/Manifest1
-rw-r--r--dev-util/debootstrap/debootstrap-1.0.111.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/debootstrap/Manifest b/dev-util/debootstrap/Manifest
index ea4f88208d68..6158dfa4b873 100644
--- a/dev-util/debootstrap/Manifest
+++ b/dev-util/debootstrap/Manifest
@@ -1,4 +1,5 @@
DIST debootstrap_1.0.109.tar.gz 74602 BLAKE2B e22239076c917bedd346b1639c80d7faf5399f66518ed67b1f1278a7cef2dfa9b0babe7691597eb1038d5f7c23086c5427a71d587214463692c65c9919914064 SHA512 6e55e14d803617b33bc00381b53c465e403f4aaf8765aecb04332e6c87e9b4fed6a23f55eabc4c11910be42bf9cbf88dacbee992754aa4e233cb79a826177cbb
DIST debootstrap_1.0.110.tar.gz 74847 BLAKE2B fe715bf7657aebfab40f4196f69c29ee0a3ee5c882e1618645cebb30e792a8bc5db3c0cbc7b0978b89462f1109a1257c9702260471f4d9c8231062f1947123b4 SHA512 5c89887073d1ddd06eeeb57cf36c908ae5a4094cafbbab1ea6cade376f6babc9bf6c981989a2a1b9b5da89f1ab8096b7283d3d7565a1d90af0174095d93f2a7f
+DIST debootstrap_1.0.111.tar.gz 75503 BLAKE2B 96489f3ea8af07b00c685b7454ea255354ea8c08e01ded40a14e9431287c6b7f347cb0960107588ecb583ddac675dd0cb92cfb876d08f91436e0015bbd5b4504 SHA512 554ad9c1b5426dcb9e1d89fff35d08c1048beabb882362b1d0b86eef76169c0fc72ccaa235717614abbacc739443dc4c8dd84119ee4cf186aa5b8f2f3cfe713b
DIST debootstrap_1.0.89.tar.gz 69020 BLAKE2B 9175d0936b6c9a28a29ee1b24bd835c41aaf807bc24a029201aaa45d07789206ee06e38b0a70c1e507ab448a3ec9c0fded2838bfb868334270b5159b34cbe9eb SHA512 3f230ce3eff6359353d106c806ce395861fb47fc1416eb0b498af7ce12a45ce7572b18284633d6d4d07b73a4a203e03bc205df3eae0db6f637237d25d0a69b1a
DIST devices.tar.gz 47835 BLAKE2B 03bfe097fda12a7a0aa19d3308c0d44382ad945defea05a63b17a72e4051ef94f0e60e75bde35baeace81da59d9f04126f6e463163609475b9c0fdf518f533ef SHA512 994ec8d72e3d52d2d872f7ff0da2336e4cbd3a5fa73bb6cdb9e06f5e7f5b8c69cea639c738fdba1186f382d6dcf62e7746fface664bfbd744aac24b16f034432
diff --git a/dev-util/debootstrap/debootstrap-1.0.111.ebuild b/dev-util/debootstrap/debootstrap-1.0.111.ebuild
new file mode 100644
index 000000000000..7bfd4fa6a357
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-1.0.111.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils
+
+DESCRIPTION="Debian/Ubuntu bootstrap scripts"
+HOMEPAGE="https://packages.qa.debian.org/d/debootstrap.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz
+ mirror://gentoo/devices.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-arch/dpkg
+ net-misc/wget
+ sys-devel/binutils
+"
+DOCS=( TODO debian/changelog )
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+ cp "${DISTDIR}"/devices.tar.gz "${S}"
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ default
+ doman debootstrap.8
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then
+ elog "To check Release files against a keyring (--keyring=K), please"
+ elog "install app-crypt/gnupg"
+ fi
+
+ if ! has_version app-crypt/debian-archive-keyring || ! has_version app-crypt/ubuntu-keyring; then
+ elog "To check Release files from Debian or Ubuntu, please install"
+ elog " app-crypt/debian-archive-keyring or"
+ elog " app-crypt/ubuntu-keyring as required"
+ fi
+}