summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-07-20 08:24:29 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-07-20 08:24:29 +0200
commitfc84c310bbbdb47d151d193da992aa2f8a95fa4b (patch)
tree26149764bb960ffa6a67e6b2aad4f41025ad8674
parentdev-util/cucumber-core: add 10.0.1 (diff)
downloadgentoo-fc84c310bbbdb47d151d193da992aa2f8a95fa4b.tar.gz
gentoo-fc84c310bbbdb47d151d193da992aa2f8a95fa4b.tar.bz2
gentoo-fc84c310bbbdb47d151d193da992aa2f8a95fa4b.zip
media-libs/libkeyfinder: bump to 2.2.5
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-libs/libkeyfinder/Manifest1
-rw-r--r--media-libs/libkeyfinder/libkeyfinder-2.2.5.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/libkeyfinder/Manifest b/media-libs/libkeyfinder/Manifest
index 5da2e2347337..625d552e9325 100644
--- a/media-libs/libkeyfinder/Manifest
+++ b/media-libs/libkeyfinder/Manifest
@@ -1 +1,2 @@
DIST libkeyfinder-2.2.4.tar.gz 79053 BLAKE2B 4d30931451625b00e1ecc2bfb6349497887ab805b5a986e05dbc51fb007a2aededcefbf9fc18c1beb7a7bc4e368c763a658979b5c5c6f7e91f4a21797ad414d7 SHA512 6673b9a81dbfa3693fc4e7af4e5fc0f351f0c60b00fdafeb9e3437e2f77b5fec7d1e78e3989ff1daca72770a1d3cdbe3837508718b8e8aba3ac3f3d56af81a56
+DIST libkeyfinder-2.2.5.tar.gz 79220 BLAKE2B a0a9b6b0d392d8da7be479e30a733f64f0c0723a1890a969ff1cc0ffc56599778148f7fe081724e83f1b3cc2217bb52f46418ed328da7d34d9229aabf24cbaef SHA512 54463d1f1111dc474d3e43723fddd5579ea1a3842f99f43e50e85622a1d6ee6fe42b22c300ce5ba5807cf6b2d7067af741773af95974a42c5d863c53165893eb
diff --git a/media-libs/libkeyfinder/libkeyfinder-2.2.5.ebuild b/media-libs/libkeyfinder/libkeyfinder-2.2.5.ebuild
new file mode 100644
index 000000000000..b102bfc23bfe
--- /dev/null
+++ b/media-libs/libkeyfinder/libkeyfinder-2.2.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Musical key detection library for digital audio"
+HOMEPAGE="https://github.com/mixxxdj/libkeyfinder"
+SRC_URI="https://github.com/mixxxdj/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ sci-libs/fftw:3.0
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "s/NAMES fftw /NAMES /" \
+ cmake/FindFFTW3.cmake || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=OFF
+ )
+
+ cmake_src_configure
+}