summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2015-08-28 16:52:15 -0700
committerMatt Turner <mattst88@gentoo.org>2015-08-28 16:57:44 -0700
commitfd221b4be7c02bf3abbc043774c810bc158671f6 (patch)
tree2593a8c2d2a91861df7aa7a21b9c1798cc8a9888
parentx11-apps/mesa-progs: Sync ebuilds. (diff)
downloadgentoo-fd221b4be7c02bf3abbc043774c810bc158671f6.tar.gz
gentoo-fd221b4be7c02bf3abbc043774c810bc158671f6.tar.bz2
gentoo-fd221b4be7c02bf3abbc043774c810bc158671f6.zip
x11-apps/mesa-progs: Remove EGL_MESA_screen_surface demos.
Not useful, and not sure when Mesa actually supported this extension, but it certainly doesn't any more. Bug: https://bugs.gentoo.org/show_bug.cgi?id=555186
-rw-r--r--x11-apps/mesa-progs/mesa-progs-8.2.0.ebuild10
-rw-r--r--x11-apps/mesa-progs/mesa-progs-9999.ebuild10
2 files changed, 6 insertions, 14 deletions
diff --git a/x11-apps/mesa-progs/mesa-progs-8.2.0.ebuild b/x11-apps/mesa-progs/mesa-progs-8.2.0.ebuild
index 81090edea198..d3c9bbf14df6 100644
--- a/x11-apps/mesa-progs/mesa-progs-8.2.0.ebuild
+++ b/x11-apps/mesa-progs/mesa-progs-8.2.0.ebuild
@@ -59,19 +59,16 @@ src_compile() {
if use egl; then
emake LDLIBS="-lEGL" -C src/egl/opengl/ eglinfo
- emake -C src/egl/eglut/ libeglut_screen.la libeglut_x11.la
+ emake -C src/egl/eglut/ libeglut_x11.la
emake LDLIBS="-lGL -lEGL -lX11 -lm" -C src/egl/opengl/ eglgears_x11
- emake LDLIBS="-lGL -lEGL -lm" -C src/egl/opengl/ eglgears_screen
if use gles1; then
emake LDLIBS="-lGLESv1_CM -lEGL -lX11" -C src/egl/opengles1/ es1_info
emake LDLIBS="-lGLESv1_CM -lEGL -lX11 -lm" -C src/egl/opengles1/ gears_x11
- emake LDLIBS="-lGLESv1_CM -lEGL -lm" -C src/egl/opengles1/ gears_screen
fi
if use gles2; then
emake LDLIBS="-lGLESv2 -lEGL -lX11" -C src/egl/opengles2/ es2_info
emake LDLIBS="-lGLESv2 -lEGL -lX11 -lm" -C src/egl/opengles2/ es2gears_x11
- emake LDLIBS="-lGLESv2 -lEGL -lm" -C src/egl/opengles2/ es2gears_screen
fi
fi
}
@@ -79,14 +76,13 @@ src_compile() {
src_install() {
dobin src/xdemos/{glxgears,glxinfo}
if use egl; then
- dobin src/egl/opengl/egl{info,gears_{screen,x11}}
+ dobin src/egl/opengl/egl{info,gears_x11}
if use gles1; then
dobin src/egl/opengles1/es1_info
- newbin src/egl/opengles1/gears_screen es1gears_screen
newbin src/egl/opengles1/gears_x11 es1gears_x11
fi
- use gles2 && dobin src/egl/opengles2/es2{_info,gears_{screen,x11}}
+ use gles2 && dobin src/egl/opengles2/es2{_info,gears_x11}
fi
}
diff --git a/x11-apps/mesa-progs/mesa-progs-9999.ebuild b/x11-apps/mesa-progs/mesa-progs-9999.ebuild
index 657291fc1e39..778c9076fa9a 100644
--- a/x11-apps/mesa-progs/mesa-progs-9999.ebuild
+++ b/x11-apps/mesa-progs/mesa-progs-9999.ebuild
@@ -59,19 +59,16 @@ src_compile() {
if use egl; then
emake LDLIBS="-lEGL" -C src/egl/opengl/ eglinfo
- emake -C src/egl/eglut/ libeglut_screen.la libeglut_x11.la
+ emake -C src/egl/eglut/ libeglut_x11.la
emake LDLIBS="-lGL -lEGL -lX11 -lm" -C src/egl/opengl/ eglgears_x11
- emake LDLIBS="-lGL -lEGL -lm" -C src/egl/opengl/ eglgears_screen
if use gles1; then
emake LDLIBS="-lGLESv1_CM -lEGL -lX11" -C src/egl/opengles1/ es1_info
emake LDLIBS="-lGLESv1_CM -lEGL -lX11 -lm" -C src/egl/opengles1/ gears_x11
- emake LDLIBS="-lGLESv1_CM -lEGL -lm" -C src/egl/opengles1/ gears_screen
fi
if use gles2; then
emake LDLIBS="-lGLESv2 -lEGL -lX11" -C src/egl/opengles2/ es2_info
emake LDLIBS="-lGLESv2 -lEGL -lX11 -lm" -C src/egl/opengles2/ es2gears_x11
- emake LDLIBS="-lGLESv2 -lEGL -lm" -C src/egl/opengles2/ es2gears_screen
fi
fi
}
@@ -79,14 +76,13 @@ src_compile() {
src_install() {
dobin src/xdemos/{glxgears,glxinfo}
if use egl; then
- dobin src/egl/opengl/egl{info,gears_{screen,x11}}
+ dobin src/egl/opengl/egl{info,gears_x11}
if use gles1; then
dobin src/egl/opengles1/es1_info
- newbin src/egl/opengles1/gears_screen es1gears_screen
newbin src/egl/opengles1/gears_x11 es1gears_x11
fi
- use gles2 && dobin src/egl/opengles2/es2{_info,gears_{screen,x11}}
+ use gles2 && dobin src/egl/opengles2/es2{_info,gears_x11}
fi
}