summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-01-17 15:13:32 -0800
committerZac Medico <zmedico@gentoo.org>2020-01-17 15:14:43 -0800
commitfd32b0f4398dab33d70044a7b2a226a361a5d7e2 (patch)
tree2ad832573ba067b21973e6110db08f27fef00124
parentsys-fs/fuse-overlayfs: Bump to version 0.7.5 (diff)
downloadgentoo-fd32b0f4398dab33d70044a7b2a226a361a5d7e2.tar.gz
gentoo-fd32b0f4398dab33d70044a7b2a226a361a5d7e2.tar.bz2
gentoo-fd32b0f4398dab33d70044a7b2a226a361a5d7e2.zip
sys-fabric/mstflint: Bump to version 4.13.3_p2
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--sys-fabric/mstflint/Manifest1
-rw-r--r--sys-fabric/mstflint/mstflint-4.13.3_p2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-fabric/mstflint/Manifest b/sys-fabric/mstflint/Manifest
index ee065f4ba6ad..9585fabb6e5b 100644
--- a/sys-fabric/mstflint/Manifest
+++ b/sys-fabric/mstflint/Manifest
@@ -1,2 +1,3 @@
DIST mstflint-4.10.0_p3.tar.gz 3208065 BLAKE2B 9d27bc41f3af4af2d430814a892bc26b302f4a57b2287cca4d5a64a37d7dd1b47e3f167b671be9ef1fadaf5dc51dff6094db811951ef1b5c6ad3ce746eb78546 SHA512 72077557f032bfa9c2c0b94f485b58c2d9efa955281997fed605e6351b1cfe73c46d8e4f293f93b58ebc4315d47b3dc3a4e8d72c8938647d34d291a2db89198f
DIST mstflint-4.11.0_p5.tar.gz 3622665 BLAKE2B 119d1ca04eaf3ebc2e4b8175525fdc87079b27742013f210f8c38d2ac0e83b46c555e4b8b49d7f1562180473c0873456932939e942b1050e9c952a2e3172185a SHA512 c98f24acda519e62fd8db8e170c39c8ffe69b980bc2c9a167f20cfcb2575038648e463de0c7dfad3ddebe098b8a466640b7a125901c033f193a42ef1bfef00d8
+DIST mstflint-4.13.3_p2.tar.gz 3809937 BLAKE2B bfe0d5a531a26547779f2e9377c4c6f393c28623d56c87a1f0210a0fbb767a43f5186c481609722ef2e5066bcdf0110009468b047ca0a8b25c096f4802b43229 SHA512 bd7e937eaed30c4b4479c3bc184d9bd8edff9aba23824fdd6a82f0e62d319854aa74954c783eb483074e322eec94f9a0cd5bd6a0ff4de2422f9b011680324706
diff --git a/sys-fabric/mstflint/mstflint-4.13.3_p2.ebuild b/sys-fabric/mstflint/mstflint-4.13.3_p2.ebuild
new file mode 100644
index 000000000000..35f63adf6dac
--- /dev/null
+++ b/sys-fabric/mstflint/mstflint-4.13.3_p2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Mstflint - an open source version of MFT (Mellanox Firmware Tools)"
+HOMEPAGE="https://github.com/Mellanox/mstflint"
+LICENSE="|| ( GPL-2 BSD-2 )"
+KEYWORDS="~amd64 ~x86"
+EGIT_COMMIT="0c3327f6bf037878d4ccc47fd46740adfc0c220e"
+MY_PV=${PV/_p/-}
+MY_P=""
+SRC_URI="https://github.com/Mellanox/mstflint/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+IUSE="inband ssl"
+SLOT="0"
+RDEPEND="dev-db/sqlite:3=
+ sys-libs/zlib:=
+ inband? ( sys-fabric/libibmad )
+ ssl? ( dev-libs/openssl:= )"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+ echo '#define TOOLS_GIT_SHA "'${EGIT_COMMIT}'"' > ./common/gitversion.h || die
+}
+
+src_configure() {
+ eautoreconf
+ econf $(use_enable inband) $(use_enable ssl openssl)
+}