summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-11-16 15:19:32 -0500
committerMike Frysinger <vapier@gentoo.org>2016-11-16 15:20:40 -0500
commitfdf00e407a5e6a674a07e983a8f2ce3f3b04185e (patch)
treed56154f19e870424c9a4f6ff4f8a8eb411db4f0c
parentwww-client/links: Fix libevent automagic dep (#573360 by Duncan) (diff)
downloadgentoo-fdf00e407a5e6a674a07e983a8f2ce3f3b04185e.tar.gz
gentoo-fdf00e407a5e6a674a07e983a8f2ce3f3b04185e.tar.bz2
gentoo-fdf00e407a5e6a674a07e983a8f2ce3f3b04185e.zip
sys-fs/udisks: fix old SLOT=0 building w/newer glibc too #580230
-rw-r--r--sys-fs/udisks/files/udisks-1.0.5-sysmacros.patch72
-rw-r--r--sys-fs/udisks/udisks-1.0.5-r1.ebuild3
2 files changed, 74 insertions, 1 deletions
diff --git a/sys-fs/udisks/files/udisks-1.0.5-sysmacros.patch b/sys-fs/udisks/files/udisks-1.0.5-sysmacros.patch
new file mode 100644
index 000000000000..96ce943d385c
--- /dev/null
+++ b/sys-fs/udisks/files/udisks-1.0.5-sysmacros.patch
@@ -0,0 +1,72 @@
+https://bugs.gentoo.org/580230
+https://bugs.freedesktop.org/95028
+
+From 245093a15abe985b1746603c00084cb972fb71ae Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 19 Apr 2016 23:04:32 -0400
+Subject: [PATCH] include sys/sysmacros.h for major/minor/makedev
+
+Linux C libraries are moving away from implicit includes of
+sys/sysmacros.h, so pull in this header directly in the files
+that use these funcs.
+
+--- a/src/daemon.c
++++ b/src/daemon.c
+@@ -38,6 +38,7 @@
+ #include <signal.h>
+ #include <errno.h>
+ #include <string.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
+--- a/src/device.c
++++ b/src/device.c
+@@ -28,6 +28,7 @@
+ #include <signal.h>
+ #include <errno.h>
+ #include <string.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <sys/stat.h>
+--- a/src/mount-monitor.c
++++ b/src/mount-monitor.c
+@@ -27,6 +27,7 @@
+ #include <signal.h>
+ #include <errno.h>
+ #include <string.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <mntent.h>
+--- a/src/probers/part-id.c
++++ b/src/probers/part-id.c
+@@ -23,6 +23,7 @@
+ #include <string.h>
+ #include <ctype.h>
+ #include <unistd.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <sys/stat.h>
+--- a/tools/udisks.c
++++ b/tools/udisks.c
+@@ -28,6 +28,7 @@
+ #include <signal.h>
+ #include <errno.h>
+ #include <string.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <sys/wait.h>
+--- a/tools/umount-udisks.c
++++ b/tools/umount-udisks.c
+@@ -28,6 +28,7 @@
+ #include <signal.h>
+ #include <errno.h>
+ #include <string.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
diff --git a/sys-fs/udisks/udisks-1.0.5-r1.ebuild b/sys-fs/udisks/udisks-1.0.5-r1.ebuild
index 5273b2441ade..5404e7518fcf 100644
--- a/sys-fs/udisks/udisks-1.0.5-r1.ebuild
+++ b/sys-fs/udisks/udisks-1.0.5-r1.ebuild
@@ -53,7 +53,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${PN}-1.0.2-ntfs-3g.patch \
"${FILESDIR}"/${PN}-1.0.4-revert-floppy.patch \
- "${FILESDIR}"/${PN}-1.0.5-stat-includes.patch
+ "${FILESDIR}"/${PN}-1.0.5-stat-includes.patch \
+ "${FILESDIR}"/${PN}-1.0.5-sysmacros.patch
sed -i -e "s:/lib/udev:$(get_udevdir):" data/80-udisks.rules || die