summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-14 18:01:10 +0000
committerSam James <sam@gentoo.org>2020-09-14 18:03:08 +0000
commitfe45222d71f8fbf6a0d61b0e76f6a73129629356 (patch)
treed675f776490fe9b562e2bcee89b26bc5fe0b8ebf
parentmail-mta/sendmail: use relative symlink for makemap (diff)
downloadgentoo-fe45222d71f8fbf6a0d61b0e76f6a73129629356.tar.gz
gentoo-fe45222d71f8fbf6a0d61b0e76f6a73129629356.tar.bz2
gentoo-fe45222d71f8fbf6a0d61b0e76f6a73129629356.zip
dev-python/sentry-sdk: bump to 0.17.5
Fix tests by: * including dev-python/eventlet testdep (only needed for one test, but there's no harm in using it) * running distutils_install_for_testing to fix integration tests and allow the others to run after the initial failure. They check for installation of sentry-sdk as a module. Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-0.17.5.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index be7cc4a2d688..43f518475261 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,3 +1,4 @@
DIST sentry-sdk-0.14.4.tar.gz 75420 BLAKE2B cbc5f401fae8a4a9eaa8f6fff8ca16a61cf2d339f14787610646112f67d7b0694d95a6076d2810968d28eb176d447fec6cf49af9a317bb2c30b4e6ab2d89a4f0 SHA512 66886df71a3d8f9f86f41bfc4078bf80f217bcb0a27fb9e93acee193b482d3045db44953f6f0b4d05e79daa91dadb56c2784b13d1308e7bc00fb40f485537dab
DIST sentry-sdk-0.16.3.tar.gz 170145 BLAKE2B bf619313fb3f49800f5384f0dfec3aa34ef4bb030c5e038a485a8861a733a537ee7c834c8c200a2244335c3c61e7d564005b81d4e5c5f603d2864b2a943a5384 SHA512 e8589f7bd433d4aff068099e860c0cf012fc88dc63806873573a338bb91848d73e0a2af76dad0a5e023a1b25b0be85507346b77dec5c5a265942005219541699
DIST sentry-sdk-0.17.4.tar.gz 180562 BLAKE2B e6061d35ff098ef79cb4b21299e3622ea9d6ffe2b5f287843ea982f3254439ed00f7d8da6bff97cd5ec485d88e1d4beb5636a43c17a0b786582e6595cb64f15f SHA512 daa9f610e9fb7ad054a579be987ca21f925166fc3491aa3a7990593fbe45a7f51a473ca016762f627d4c07bcca249b2972694b832644e23484fd067e87f59d7d
+DIST sentry-sdk-0.17.5.tar.gz 183114 BLAKE2B a2fdd5fb0ffb18f7987eae9f3837a4bf4df20df9757d89bcc3ec18f7022d20de083c905f6edbb854bcc7f074f6d158cbf30f69d953a75048e7d9d0d98e859477 SHA512 5f0d6679832fed346d00b27bac9f680909a7ede38e46b1c05c583fcc574edc193d855dba2f11a629e2919da5e13cc2e89f6c0b231e47bc7b0a67138ff7905d9f
diff --git a/dev-python/sentry-sdk/sentry-sdk-0.17.5.ebuild b/dev-python/sentry-sdk/sentry-sdk-0.17.5.ebuild
new file mode 100644
index 000000000000..89a0a6dd3b2a
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-0.17.5.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="https://getsentry.com https://pypi.org/project/sentry-sdk/"
+SRC_URI="https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ <dev-python/dnspython-2[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/aiocontextvars[${PYTHON_USEDEP}]
+ dev-python/contextvars[${PYTHON_USEDEP}]
+ ' python3_6)
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # tests require Internet access
+ --deselect tests/integrations/stdlib/test_httplib.py
+ --deselect tests/integrations/requests/test_requests.py
+ # wtf is it supposed to do?!
+ --deselect tests/integrations/gcp/test_gcp.py
+ # fails on py3.6, hangs on py3.7+
+ --deselect
+ 'tests/test_transport.py::test_transport_works[eventlet'
+ # TODO
+ --deselect
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ --deselect
+ tests/test_client.py::test_databag_depth_stripping
+ --deselect
+ tests/test_client.py::test_databag_string_stripping
+ --deselect
+ tests/test_client.py::test_databag_breadth_stripping
+ # test_filename: apparently unhappy about pytest being called pytest
+ --deselect 'tests/utils/test_general.py::test_filename'
+ # test_circular_references: apparently fragile
+ --deselect
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ )
+ [[ ${EPYTHON} == python3.6 ]] && deselect+=(
+ # broken with contextvars on py3.6
+ --deselect
+ 'tests/utils/test_contextvars.py::test_leaks[greenlet]'
+ --deselect
+ 'tests/test_transport.py::test_transport_works[greenlet'
+ )
+
+ # Prevent tests/integrations/modules/test_modules.py:test_basic failure
+ # Needs to detect sentry-sdk in the installed modules
+ distutils_install_for_testing
+
+ pytest -vv "${deselect[@]}" || die "Tests failed with ${EPYTHON}"
+}