summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-09 15:44:48 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-09 17:14:25 +0200
commitfe7b0ba8193fae1bedcd5637695ff5a06ddb85a8 (patch)
treec6aee83247d34cdf8294a9eb9052a65446450cfc
parentwww-apache/mod_h2: 1.15.11 version bump (diff)
downloadgentoo-fe7b0ba8193fae1bedcd5637695ff5a06ddb85a8.tar.gz
gentoo-fe7b0ba8193fae1bedcd5637695ff5a06ddb85a8.tar.bz2
gentoo-fe7b0ba8193fae1bedcd5637695ff5a06ddb85a8.zip
dev-python/jupyter_console: Bump to 6.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyter_console/Manifest1
-rw-r--r--dev-python/jupyter_console/jupyter_console-6.1.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jupyter_console/Manifest b/dev-python/jupyter_console/Manifest
index 4b8519652e5d..2e173379d35b 100644
--- a/dev-python/jupyter_console/Manifest
+++ b/dev-python/jupyter_console/Manifest
@@ -1 +1,2 @@
DIST jupyter_console-6.0.0.tar.gz 27780 BLAKE2B da2b58461caa987bea0b323cedbc79ff24f31cb928602b8ae6dce1ed615008a8227d7a1bab47364e6d182cfd3bd6f548e355430efc505e7183a391ef26c08375 SHA512 27b333f439733c33062d3baa8b49ff673b10e22cb8c28c688ba604799838e899f93372bd2eaf4a94c97260d6dec043d6aef4421388d77e625b1ec43a3dedfa3f
+DIST jupyter_console-6.1.0.tar.gz 28468 BLAKE2B 08ef158de6a0eb8fe741dac00b74e11f7e577b5097f54aa16c47ae9e39607231e19a1fcd0a96cbae41d41fad891fefdb532d0f66bc03aa66ff99a8d3ff3cb28c SHA512 abb5457a90d109457e91071cd8b592a14bec7ead75fd667d656f9180a457e39bf470877b2e17c81ff512d1cc69b62a8f700996492f6164eb05a1581db82abbf7
diff --git a/dev-python/jupyter_console/jupyter_console-6.1.0.ebuild b/dev-python/jupyter_console/jupyter_console-6.1.0.ebuild
new file mode 100644
index 000000000000..d113b9fecd96
--- /dev/null
+++ b/dev-python/jupyter_console/jupyter_console-6.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A terminal-based console frontend for Jupyter kernels"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ <dev-python/prompt_toolkit-3.1.0[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ "
+# util-linux provides script(1)
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ sys-apps/util-linux
+ )
+ "
+
+distutils_enable_sphinx docs
+distutils_enable_tests nose
+
+python_test() {
+ script -eqc "nosetests -v" || die
+}