summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-11-10 23:28:47 -0500
committerMatt Turner <mattst88@gentoo.org>2020-11-10 23:29:55 -0500
commitff00257a1a779d850ca017a550bf490cba1b6546 (patch)
tree66f9bcee3cb538e44279d8d845600ecf32582656
parentdev-libs/libpwquality: Version bump to 1.4.4 (diff)
downloadgentoo-ff00257a1a779d850ca017a550bf490cba1b6546.tar.gz
gentoo-ff00257a1a779d850ca017a550bf490cba1b6546.tar.bz2
gentoo-ff00257a1a779d850ca017a550bf490cba1b6546.zip
net-wireless/gnome-bluetooth: Version bump to 3.34.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--net-wireless/gnome-bluetooth/Manifest1
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.3.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/Manifest b/net-wireless/gnome-bluetooth/Manifest
index 38fdbd9259e2..f2b6acd8bcc0 100644
--- a/net-wireless/gnome-bluetooth/Manifest
+++ b/net-wireless/gnome-bluetooth/Manifest
@@ -1 +1,2 @@
DIST gnome-bluetooth-3.34.1.tar.xz 354568 BLAKE2B 53e0f4d172e12ba1fec8dae476929fadaab2fd0a8e8ac063debbe516f925a3bb04c9000012fc2e143baf00c7bbdd4f2bd31bd64e674c1851e4ec544ab9c058a5 SHA512 3e0080bbeeddc144fdcf6b4f0d59b0885fd5881aee670d2e5dffd4ede9b0f988358ad0e815ba86add8b7fd5e93e1f8fc7bfacd10b8d69606aa569fd67356be08
+DIST gnome-bluetooth-3.34.3.tar.xz 353032 BLAKE2B fbf75328780d54307ebf6f8d9d58080060d05b3d76665e3c09f3d2bbc033dbda87a7d4eb43d8fe751955f8240febc13d0446cab1bac085c4a73e9c4e9ff25033 SHA512 a20985576fbc0594a198c8f58e6098db24c73454a9dfc0f5f47581a1bfc0a72e3f0d2592f4a01593c5ed132e4924d934d4d65fd501d274f3b032e1e548794272
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.3.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.3.ebuild
new file mode 100644
index 000000000000..29311e2afa0f
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson udev xdg
+
+DESCRIPTION="Bluetooth graphical utilities integrated with GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeBluetooth"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="2/13" # subslot = libgnome-bluetooth soname version
+IUSE="gtk-doc +introspection"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.38:2
+ >=x11-libs/gtk+-3.12:3[introspection?]
+ media-libs/libcanberra[gtk3]
+ >=x11-libs/libnotify-0.7.0
+ virtual/libudev
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}
+ acct-group/plugdev
+ virtual/udev
+ >=net-wireless/bluez-5
+"
+BDEPEND="
+ >=dev-util/meson-0.49.0
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.9 )
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dicon_update=false
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ udev_dorules "${FILESDIR}"/61-${PN}.rules
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ if ! has_version 'sys-auth/consolekit[acl]' && ! has_version 'sys-apps/systemd[acl]' ; then
+ elog "Don't forget to add yourself to the plugdev group "
+ elog "if you want to be able to control bluetooth transmitter."
+ fi
+}