summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-20 11:57:22 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-24 12:29:36 +0200
commit6367bdfeae97ba6c85b1f0e58182dcd0bb9cd0ba (patch)
tree34c6c1488a282826c038893aeaf539794bb4fd18 /acct-user/postmaster/postmaster-0.ebuild
parentacct-user/mail: Add 'mail' user (UID 8 on Linux) (diff)
downloadgentoo-6367bdfeae97ba6c85b1f0e58182dcd0bb9cd0ba.tar.gz
gentoo-6367bdfeae97ba6c85b1f0e58182dcd0bb9cd0ba.tar.bz2
gentoo-6367bdfeae97ba6c85b1f0e58182dcd0bb9cd0ba.zip
acct-user/postmaster: Add 'postmaster' user (UID 14)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'acct-user/postmaster/postmaster-0.ebuild')
-rw-r--r--acct-user/postmaster/postmaster-0.ebuild15
1 files changed, 15 insertions, 0 deletions
diff --git a/acct-user/postmaster/postmaster-0.ebuild b/acct-user/postmaster/postmaster-0.ebuild
new file mode 100644
index 000000000000..6f182fb97170
--- /dev/null
+++ b/acct-user/postmaster/postmaster-0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="Postmaster user"
+ACCT_USER_ID=14
+ACCT_USER_HOME=/var/spool/mail
+ACCT_USER_HOME_OWNER=root:mail
+ACCT_USER_HOME_PERMS=03775
+ACCT_USER_GROUPS=( mail )
+
+acct-user_add_deps