summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-12-06 16:42:37 +0000
committerMarek Szuba <marecki@gentoo.org>2021-12-09 12:03:15 +0000
commit4714d7ba8615baaa039fe1e6524e43452be89ac3 (patch)
tree01c1d627ea0d45fdba6b6797288c774227b52c06 /acct-user/strelaysrv
parentacct-user/stdiscosrv: new home directory and main group (diff)
downloadgentoo-4714d7ba8615baaa039fe1e6524e43452be89ac3.tar.gz
gentoo-4714d7ba8615baaa039fe1e6524e43452be89ac3.tar.bz2
gentoo-4714d7ba8615baaa039fe1e6524e43452be89ac3.zip
acct-user/strelaysrv: new home directory and main group
To reflect upstream changes to their init scripts and systemd units, apart from the user name itself - that would be more annoying to fix. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'acct-user/strelaysrv')
-rw-r--r--acct-user/strelaysrv/strelaysrv-1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/acct-user/strelaysrv/strelaysrv-1.ebuild b/acct-user/strelaysrv/strelaysrv-1.ebuild
new file mode 100644
index 000000000000..c4b804d8160c
--- /dev/null
+++ b/acct-user/strelaysrv/strelaysrv-1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit acct-user
+
+DESCRIPTION="User for the Syncthing relay server"
+ACCT_USER_ID=496
+ACCT_USER_HOME=/var/lib/syncthing-relaysrv
+ACCT_USER_HOME_PERMS=0770
+ACCT_USER_GROUPS=( syncthing )
+
+acct-user_add_deps
+
+pkg_postinst() {
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ local rver
+ for rver in ${REPLACING_VERSIONS} ; do
+ if ver_test "${rver}" -lt 1; then
+ ewarn "The home directory of this user has changed to /var/lib/syncthing-relaysrv"
+ ewarn "If you have any files in /var/lib/${PN}, move them to the new location by hand"
+ break
+ fi
+ done
+ fi
+}