summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2019-12-20 13:24:55 +0000
committerMarek Szuba <marecki@gentoo.org>2019-12-27 14:40:03 +0100
commit162a4f3cbefde03dd22728cef773472b6cc79e8e (patch)
tree83328bd42229de77bd472ec248943ff0cabc6465 /acct-user
parentacct-group/xrootd: new group for GID 469 (diff)
downloadgentoo-162a4f3cbefde03dd22728cef773472b6cc79e8e.tar.gz
gentoo-162a4f3cbefde03dd22728cef773472b6cc79e8e.tar.bz2
gentoo-162a4f3cbefde03dd22728cef773472b6cc79e8e.zip
acct-user/xrootd: new user for UID 469
enewuser in net-libs/xrootd ebuilds has set the home directory to "${EPREFIX}"/var/spool/xrootd but as far as I can recall from my personal experience or see in the documentation, it isn't really necessary for that user to have a home directory. Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'acct-user')
-rw-r--r--acct-user/xrootd/metadata.xml8
-rw-r--r--acct-user/xrootd/xrootd-0.ebuild12
2 files changed, 20 insertions, 0 deletions
diff --git a/acct-user/xrootd/metadata.xml b/acct-user/xrootd/metadata.xml
new file mode 100644
index 000000000000..46a304a17de5
--- /dev/null
+++ b/acct-user/xrootd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-physics@gentoo.org</email>
+ <name>Gentoo Physics Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/acct-user/xrootd/xrootd-0.ebuild b/acct-user/xrootd/xrootd-0.ebuild
new file mode 100644
index 000000000000..7b0eaaf9584c
--- /dev/null
+++ b/acct-user/xrootd/xrootd-0.ebuild
@@ -0,0 +1,12 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="User for the XRootD server"
+ACCT_USER_ID=469
+ACCT_USER_GROUPS=( "${PN}" )
+
+acct-user_add_deps