summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-09-17 19:08:34 +0200
committerBen Kohler <bkohler@gentoo.org>2019-09-17 13:30:05 -0500
commit3d95aaace8611167e938a6f44e42a18754a53020 (patch)
tree8863c373ef8cb2fe981d0fc39f486837af610ed5 /acct-user
parentacct-group/unifi: add group for net-wireless/unifi (diff)
downloadgentoo-3d95aaace8611167e938a6f44e42a18754a53020.tar.gz
gentoo-3d95aaace8611167e938a6f44e42a18754a53020.tar.bz2
gentoo-3d95aaace8611167e938a6f44e42a18754a53020.zip
acct-user/unifi: add user for net-wireless/unifi
UID 113 will be used, as Arch also uses this one. Fedora and RHEL don't have a reserved UID. Bug: https://bugs.gentoo.org/694684 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Manifest-Sign-Key: 5646E9134B279879CD890EB80910C5FCDF5469A3 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'acct-user')
-rw-r--r--acct-user/unifi/metadata.xml22
-rw-r--r--acct-user/unifi/unifi-0.ebuild15
2 files changed, 37 insertions, 0 deletions
diff --git a/acct-user/unifi/metadata.xml b/acct-user/unifi/metadata.xml
new file mode 100644
index 000000000000..57ba2066974e
--- /dev/null
+++ b/acct-user/unifi/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bkohler@gentoo.org</email>
+ <name>Ben Kohler</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ UniFi is a management controller software for Ubiquiti UniFi APs.
+ It's purpose is to configure and monitor all those APs.
+ Also all kind of statistics are collected, which can be accessed through UniFi.
+ There is also an internal RADIUS server, which can be used for WPA2-Enterprise.
+ </longdescription>
+</pkgmetadata>
diff --git a/acct-user/unifi/unifi-0.ebuild b/acct-user/unifi/unifi-0.ebuild
new file mode 100644
index 000000000000..0f750e70188e
--- /dev/null
+++ b/acct-user/unifi/unifi-0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="A user for the UniFi Controller"
+
+ACCT_USER_GROUPS=( "unifi" )
+ACCT_USER_HOME="/var/lib/unifi"
+ACCT_USER_HOME_OWNER="unifi:unifi"
+ACCT_USER_ID="113"
+
+acct-user_add_deps