summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-03-08 21:03:38 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-03-09 07:55:10 +0200
commit81b2e9fc9306cec4d6cd9d1614b4fad8321dae87 (patch)
tree871facc765108742064decf66ce7ebf7863c7bfe /acct-user
parentdev-util/cutter: Bump to 1.10.1 (diff)
downloadgentoo-81b2e9fc9306cec4d6cd9d1614b4fad8321dae87.tar.gz
gentoo-81b2e9fc9306cec4d6cd9d1614b4fad8321dae87.tar.bz2
gentoo-81b2e9fc9306cec4d6cd9d1614b4fad8321dae87.zip
acct-user/minetest: Add home directory
Minetest requires a home directory to store user data. This patch adds /var/lib/minetest as the default home directory for the minetest user. Bug: https://bugs.gentoo.org/709530 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14890 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'acct-user')
-rw-r--r--acct-user/minetest/minetest-1.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/acct-user/minetest/minetest-1.ebuild b/acct-user/minetest/minetest-1.ebuild
new file mode 100644
index 000000000000..728978354ba5
--- /dev/null
+++ b/acct-user/minetest/minetest-1.ebuild
@@ -0,0 +1,14 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="A user for the Minetest server"
+
+ACCT_USER_GROUPS=( "minetest" )
+ACCT_USER_ID="480"
+ACCT_USER_HOME="/var/lib/minetest"
+
+acct-user_add_deps