summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility/festival-it/festival-it-1.0-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility/festival-it/festival-it-1.0-r2.ebuild')
-rw-r--r--app-accessibility/festival-it/festival-it-1.0-r2.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/app-accessibility/festival-it/festival-it-1.0-r2.ebuild b/app-accessibility/festival-it/festival-it-1.0-r2.ebuild
new file mode 100644
index 000000000000..7a3a3dacf304
--- /dev/null
+++ b/app-accessibility/festival-it/festival-it-1.0-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="A collection of italian voices for Festival TTS"
+HOMEPAGE="http://www2.pd.istc.cnr.it/FESTIVAL/home"
+SRC_URI="mirror://sourceforge/it-festival/Italian-FESTIVAL.zip"
+
+RDEPEND=">=app-accessibility/festival-2.1
+ mbrola? ( >=app-accessibility/mbrola-3.0.1h-r4[linguas_it] )"
+DEPEND="app-arch/unzip"
+IUSE="mbrola"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}
+
+src_prepare() {
+
+ unzip -qo italian_scm.zip
+ unzip -qo lex_ifd.zip
+ unzip -qo lp_diphone.zip
+ unzip -qo pc_diphone.zip
+
+ if use mbrola; then
+ unzip -qo lp_mbrola_unix.zip
+ unzip -qo pc_mbrola_unix.zip
+ fi
+
+ # Deletes some useless files
+ rm -f *.zip
+
+ rm -f `find festival/ -name install_unix.txt`
+ rm -f `find festival/ -name italian_mbrola_win.scm`
+
+ if ! use mbrola; then
+ rm -f `find festival/ -name italian_mbrola_unix.scm`
+ fi
+
+ # Aggregates some README files
+ mkdir docs
+ mv `find festival/ -name \*README` docs/
+
+ # All remaining files are moved "here"
+ mv festival/lib/* .
+ rm -rf festival/
+}
+
+src_install () {
+ # Install the docs
+ dodoc "${WORKDIR}"/docs/*
+
+ # Install the voice scheme
+ insinto /usr/share/festival/
+ doins -r "${WORKDIR}"/italian_scm/
+
+ # Install the dicts
+ insinto /usr/share/festival/dicts
+ doins -r "${WORKDIR}"/dicts/*
+
+ # Installs the voices
+ insinto /usr/share/festival/voices
+ doins -r "${WORKDIR}"/voices/*
+
+ # Enables the mbrola-based voices
+ if use mbrola; then
+ dosym /opt/mbrola/it3 /usr/share/festival/voices/italian/pc_mbrola/it3
+ dosym /opt/mbrola/it4 /usr/share/festival/voices/italian/lp_mbrola/it4
+ fi
+}
+
+pkg_postinst () {
+ einfo "Italian voices installed:"
+ for VOICE in `ls "${ROOT}/usr/share/festival/voices/italian/"`; do
+ einfo " (voice_${VOICE})"
+ done
+}