summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-03-22 08:27:15 -0500
committerAaron Bauman <bman@gentoo.org>2018-03-26 16:19:46 -0400
commitd6ba21c23c6d5fd742a9962919e5af62aa643ee7 (patch)
treec8e557f784080191b26aed6244612acf6b87e623 /app-accessibility/julius/julius-4.2.2.ebuild
parentapp-accessibility/flite: EAPI bump and patch updates (diff)
downloadgentoo-d6ba21c23c6d5fd742a9962919e5af62aa643ee7.tar.gz
gentoo-d6ba21c23c6d5fd742a9962919e5af62aa643ee7.tar.bz2
gentoo-d6ba21c23c6d5fd742a9962919e5af62aa643ee7.zip
app-accessibility/julius: EAPI bump and patch updates
Bump EAPI to 6 and clean up the patches a bit. turn the LINGUAS check into a proper l10n_ja USE check. Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7587
Diffstat (limited to 'app-accessibility/julius/julius-4.2.2.ebuild')
-rw-r--r--app-accessibility/julius/julius-4.2.2.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/app-accessibility/julius/julius-4.2.2.ebuild b/app-accessibility/julius/julius-4.2.2.ebuild
index 7cf68ebb5a72..6c41e4be6171 100644
--- a/app-accessibility/julius/julius-4.2.2.ebuild
+++ b/app-accessibility/julius/julius-4.2.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Large Vocabulary Continuous Speech Recognition Engine"
HOMEPAGE="http://julius.sourceforge.jp/"
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge.jp/julius/56549/${P}.tar.gz"
LICENSE="julius"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="+alsa oss portaudio pulseaudio sndfile"
+IUSE="+alsa l10n_ja oss portaudio pulseaudio sndfile"
REQUIRED_USE="^^ ( alsa oss portaudio pulseaudio )"
RDEPEND="
@@ -27,15 +27,15 @@ RDEPEND="
DEPEND="${RDEPEND}
sys-devel/flex"
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.2.2-install.patch
+ "${FILESDIR}"/${PN}-4.2.2-ldflags.patch
+)
+
pkg_setup() {
tc-export CC CXX
}
-src_prepare() {
- epatch "${FILESDIR}"/${P}-install.patch \
- "${FILESDIR}"/${P}-ldflags.patch
-}
-
src_configure() {
local mymic i
for i in alsa oss portaudio pulseaudio ; do
@@ -49,7 +49,7 @@ src_configure() {
src_install() {
default
- if ! has ja ${LINGUAS} ; then
+ if ! use l10n_ja ; then
rm -r "${ED}"/usr/share/man/ja || die
fi
}