summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-10-04 13:05:42 +0200
committerPacho Ramos <pacho@gentoo.org>2015-10-04 13:06:30 +0200
commit14a7c527cd17e0761973932a86ebc2f91838f392 (patch)
tree1d69c877c776998c76f43d5596801efd0d8fc323 /app-accessibility/orca
parentgames-emulation/mupen64plus-core: Use DejaVu font, #548214 (diff)
downloadgentoo-14a7c527cd17e0761973932a86ebc2f91838f392.tar.gz
gentoo-14a7c527cd17e0761973932a86ebc2f91838f392.tar.bz2
gentoo-14a7c527cd17e0761973932a86ebc2f91838f392.zip
app-accessibility/orca: Version bump
Package-Manager: portage-2.2.22
Diffstat (limited to 'app-accessibility/orca')
-rw-r--r--app-accessibility/orca/Manifest1
-rw-r--r--app-accessibility/orca/orca-3.16.3.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index 1e055df5bd8b..bc870e23dc11 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,3 +1,4 @@
DIST orca-3.14.3.tar.xz 1998804 SHA256 8258dc3174572a4bf1a266ad36df46cf5f2c5a8dc5df1a071f49f812bec2a315 SHA512 579eb592ab99a98598ce7405e180b9e8657c5b418d792f1209684bca7b309bb8e0857fd2766a39fb53835ae44f12e3447dda08402b21113e16c92bb7f60e661d WHIRLPOOL 624fc3c89ad20e734ab61160839a4d469243c587ed8c72b413ee011275e27eff73ac8ffa82f03dfa69902450c0db970b402d4b371e647298ee4b193218851e64
DIST orca-3.14.4.tar.xz 2016596 SHA256 94a522e0a29143858be0d092346d9996e62b55fefdf4651b5edf79bcb9f4a1ef SHA512 1270c18c83817f02c0804db711915d112ff8e3b336c2dd39eb3ff5e2110393ce0afb030f82bdefb1a56acf6471107d2f237100aa22b85ac88ab04c7325cebfc8 WHIRLPOOL 298004708658a62d8fde7bb0f2ec53a7d4b64188ed663cfc5edd7d788bcc8de7f07bff5ce58ad625572692233652a251e2666640f1309d23a7ab67574cd20125
DIST orca-3.16.2.tar.xz 2078728 SHA256 cd14b28878cc04166ec43c7d9a8e6b0056c66cbfb1e4f934f12f74568937789a SHA512 768628c4630d84929a8a2b12b73771de7b104b1754e9462b1fe63c2bbadca192e56416a1e2a43ad5f5594c91a4fe94941d2deb1e44cccaf253d4f03704f31ee1 WHIRLPOOL eea3f9a1a0b1aebb4ca3a6da1a5cf016b1ea6d042c4e8e1b7275325cd08e77c6a7c6519048651ace34ef10d69c22663e9009dab20502ff3fca7d6c6c9a888c9a
+DIST orca-3.16.3.tar.xz 2124800 SHA256 540deeaa1a973cc7ccc8a463f8fcf51db51f7ccfb130bc2019ac53bf67943dc7 SHA512 c579437d956bee014db61aeb7494a295345e28a147a938a71a8062c30de67fcff3767c5ea8767067ce5f2f5ff84c0aaf2fc250730e4a7036ae100078fd6f058f WHIRLPOOL 839b3c7170f2fd44fa5b97cfd9ed6989dd94721d379d21428a166b8321fb5162a56f758327df0ea632bf320711362b0e03916358d023fba8dffec2a36f62b970
diff --git a/app-accessibility/orca/orca-3.16.3.ebuild b/app-accessibility/orca/orca-3.16.3.ebuild
new file mode 100644
index 000000000000..00c80932503a
--- /dev/null
+++ b/app-accessibility/orca/orca-3.16.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{3,4} )
+PYTHON_REQ_USE="threads"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# liblouis is not in portage yet
+# it is used to provide contracted braille support
+# XXX: Check deps for correctness
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-atk-2.10:2
+ >=app-accessibility/at-spi2-core-2.10:2[introspection]
+ >=dev-libs/atk-2.10
+ >=dev-libs/glib-2.28:2
+ >=dev-python/pygobject-3.10:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ braille? (
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ dev-libs/atk[introspection]
+ dev-python/pyatspi[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+ installing() {
+ gnome2_src_install
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#!'"${PYTHON}:#!/usr/bin/python:" \
+ -i src/orca/orca || die
+ python_doscript src/orca/orca
+ }
+ python_foreach_impl run_in_build_dir installing
+}