summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility/speakup/speakup-3.1.6_p201011120508.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility/speakup/speakup-3.1.6_p201011120508.ebuild')
-rw-r--r--app-accessibility/speakup/speakup-3.1.6_p201011120508.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/app-accessibility/speakup/speakup-3.1.6_p201011120508.ebuild b/app-accessibility/speakup/speakup-3.1.6_p201011120508.ebuild
new file mode 100644
index 000000000000..4f5e7693e502
--- /dev/null
+++ b/app-accessibility/speakup/speakup-3.1.6_p201011120508.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="http://linux-speakup.org/speakup.git"
+ vcs=git-2
+else
+ SRC_URI="ftp://linux-speakup.org/pub/speakup/${P}.tar.bz2"
+ KEYWORDS="amd64 x86"
+fi
+
+inherit $vcs linux-mod
+
+DESCRIPTION="The speakup linux kernel based screen reader"
+HOMEPAGE="http://linux-speakup.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="modules"
+
+S="${WORKDIR}/${PN}-3.1.6"
+MODULE_NAMES="speakup(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_acntpc(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_acntsa(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_apollo(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_audptr(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_bns(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_decext(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_decpc(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_dectlk(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_dtlk(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_dummy(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_keypc(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_ltlk(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_soft(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_spkout(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_txprt(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)"
+BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
+BUILD_TARGETS="clean all"
+
+src_prepare() {
+ use modules && cmd=die || cmd=ewarn
+ if ! kernel_is 2 6 36; then
+ $cmd "This version of speakup requires kernel version 2.6.36"
+ fi
+}
+
+src_compile() {
+ use modules && linux-mod_src_compile
+}
+
+src_install() {
+ use modules && linux-mod_src_install
+ dodoc Bugs.txt README To-Do
+ dodoc drivers/staging/speakup/DefaultKeyAssignments
+ dodoc drivers/staging/speakup/spkguide.txt
+}
+
+pkg_postinst() {
+ use modules && linux-mod_pkg_postinst
+
+ elog "You must set up the speech synthesizer driver to be loaded"
+ elog "automatically in order for your system to start speaking"
+ elog "when it is booted."
+ if has_version "<sys-apps/baselayout-2"; then
+ elog "this is done via /etc/modules.autoload.d/kernel-2.6"
+ else
+ elog "This is done via /etc/conf.d/modules."
+ fi
+}