summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-03-22 10:10:41 -0500
committerAaron Bauman <bman@gentoo.org>2018-05-31 09:22:56 -0400
commitd1818df330a374f668db868f1be2086839530d5b (patch)
tree3989eb16f355a6b7b21eda9f129e1bcd7f5d2a89 /app-accessibility/yasr/yasr-0.6.9-r1.ebuild
parentprofiles: mask net-analyzer/wireshark[doc] on alpha (diff)
downloadgentoo-d1818df330a374f668db868f1be2086839530d5b.tar.gz
gentoo-d1818df330a374f668db868f1be2086839530d5b.tar.bz2
gentoo-d1818df330a374f668db868f1be2086839530d5b.zip
app-accessibility/yasr: EAPI bump and patches cleanup
Bump EAPI to 6, cleanup patches, remove eutils, move dosed from src_install to src_prepare (and change it to normal sed -i), allow building with sys-devel/gettext-0.19.8.1 Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7583
Diffstat (limited to 'app-accessibility/yasr/yasr-0.6.9-r1.ebuild')
-rw-r--r--app-accessibility/yasr/yasr-0.6.9-r1.ebuild42
1 files changed, 22 insertions, 20 deletions
diff --git a/app-accessibility/yasr/yasr-0.6.9-r1.ebuild b/app-accessibility/yasr/yasr-0.6.9-r1.ebuild
index 2bf8a4603be6..9c0ccb97b096 100644
--- a/app-accessibility/yasr/yasr-0.6.9-r1.ebuild
+++ b/app-accessibility/yasr/yasr-0.6.9-r1.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit autotools eutils
+EAPI=6
-DESCRIPTION="general-purpose console screen reader"
+inherit autotools
+
+DESCRIPTION="General-purpose console screen reader"
HOMEPAGE="http://yasr.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -16,16 +17,27 @@ IUSE="nls"
RDEPEND=""
DEPEND="nls? ( sys-devel/gettext )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.9-automake113.patch
+ "${FILESDIR}"/${PN}-0.6.9-gettext019.patch
+ "${FILESDIR}"/${PN}-0.6.9-gcc43.patch
+ "${FILESDIR}"/${PN}-0.6.9-remove-m4.patch
+)
+
src_prepare() {
+ default
local x=/usr/share/gettext/po/Makefile.in.in
- [[ -e $x ]] && cp -f $x po/ #330879
+ [[ -e $x ]] && cp -f $x po/ || die #330879
+
+ rm -r "${S}"/m4 || die
- epatch "${FILESDIR}"/${P}-automake113.patch \
- "${FILESDIR}"/${P}-gettext018.patch \
- "${FILESDIR}"/${P}-gcc43.patch \
- "${FILESDIR}"/${P}-remove-m4.patch
+ sed -i \
+ 's:^\(synthesizer=emacspeak server\):#\1:
+ s:^\(synthesizer port=|/usr/local/bin/eflite\):#\1:
+ s:^#\(synthesizer=speech dispatcher\):\1:
+ s:^#\(synthesizer port=127.0.0.1.6560\):\1:' yasr.conf || die
- rm -r "${S}"/m4
+ mv configure.{in,ac} || die
eautoreconf
}
@@ -36,16 +48,6 @@ src_configure() {
$(use_enable nls)
}
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc README ChangeLog AUTHORS BUGS CREDITS
- dosed \
- 's:^\(synthesizer=emacspeak server\):#\1:
- s:^\(synthesizer port=|/usr/local/bin/eflite\):#\1:
- s:^#\(synthesizer=speech dispatcher\):\1:
- s:^#\(synthesizer port=127.0.0.1.6560\):\1:' /etc/yasr/yasr.conf
-}
-
pkg_postinst() {
elog
elog "Speech-dispatcher is configured as the default synthesizer for yasr."