summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility/yasr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility/yasr')
-rw-r--r--app-accessibility/yasr/Manifest1
-rw-r--r--app-accessibility/yasr/files/yasr-0.6.9-automake113.patch17
-rw-r--r--app-accessibility/yasr/files/yasr-0.6.9-gcc43.patch26
-rw-r--r--app-accessibility/yasr/files/yasr-0.6.9-gettext018.patch13
-rw-r--r--app-accessibility/yasr/files/yasr-0.6.9-remove-m4.patch29
-rw-r--r--app-accessibility/yasr/metadata.xml8
-rw-r--r--app-accessibility/yasr/yasr-0.6.9-r1.ebuild54
7 files changed, 148 insertions, 0 deletions
diff --git a/app-accessibility/yasr/Manifest b/app-accessibility/yasr/Manifest
new file mode 100644
index 000000000000..4a8f0d1ac2b7
--- /dev/null
+++ b/app-accessibility/yasr/Manifest
@@ -0,0 +1 @@
+DIST yasr-0.6.9.tar.gz 235768 SHA256 41f17cfab8e88824a8dc1476602a0944b9030a8f8da2538a7a6549e3534e3bdf SHA512 107af558fce20bd79b81d68915032e511aa44df33a37b82ee2e82fb0d60ee14759d9b4dfe8634fdf1926c8b5c57e89aad1966e2dba243b725e72f783fe123df4 WHIRLPOOL f8db1799ab82f6373750b1e72486fd995e33da0d55e866dbc9df4fc475588e82f04015a1668ccaad4c6b3c664bf155420a37ab4ecc8b48fa1419010689f57e2c
diff --git a/app-accessibility/yasr/files/yasr-0.6.9-automake113.patch b/app-accessibility/yasr/files/yasr-0.6.9-automake113.patch
new file mode 100644
index 000000000000..2fbc32c2e986
--- /dev/null
+++ b/app-accessibility/yasr/files/yasr-0.6.9-automake113.patch
@@ -0,0 +1,17 @@
+diff --git a/configure.in b/configure.in
+index d78e8b2..15e8666 100644
+--- a/configure.in
++++ b/configure.in
+@@ -2,11 +2,10 @@ dnl Process this file with autoconf to produce a configure script.
+
+ AC_INIT(yasr, 0.6.9, mgorse@alum.wpi.edu)
+ AM_INIT_AUTOMAKE()
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+
+ AC_ISC_POSIX
+ AC_PROG_CC
+-AM_PROG_CC_STDC
+ AC_HEADER_STDC
+ AC_PROG_INSTALL
+ dnl Checks for libraries.
diff --git a/app-accessibility/yasr/files/yasr-0.6.9-gcc43.patch b/app-accessibility/yasr/files/yasr-0.6.9-gcc43.patch
new file mode 100644
index 000000000000..ee2b1a6ef7bd
--- /dev/null
+++ b/app-accessibility/yasr/files/yasr-0.6.9-gcc43.patch
@@ -0,0 +1,26 @@
+diff -NrU5 yasr-0.6.9.orig/yasr/yasr.h yasr-0.6.9/yasr/yasr.h
+--- yasr-0.6.9.orig/yasr/yasr.h 2008-06-29 01:23:44.000000000 +0200
++++ yasr-0.6.9/yasr/yasr.h 2008-06-29 01:37:00.000000000 +0200
+@@ -306,22 +306,10 @@
+ extern void opt_say(int num, int flag);
+ extern void opt_set(int num, void *val);
+ extern void opt_queue_empty(int ll);
+ extern void opt_write(FILE * fp);
+
+-/* openpty.c prototypes */
+-extern int openpty(int *, int *, char *, struct termios *, struct winsize *);
+-
+-/* cfmakeraw.c prototypes */
+-extern void cfmakeraw(struct termios *);
+-
+-/* login_tty.c prototypes */
+-extern int login_tty(int);
+-
+-/* forkpty.c prototypes */
+-extern int forkpty(int *, char *, struct termios *, struct winsize *);
+-
+ /* tbc - Would it be more efficient to ensure that "blank" grids always held
+ ascii 0x20 rather than ascii 0x00? */
+ #define y_isblank(ch) ((ch & 0xdf) == 0)
+ #define cblank(r, c) ((win->row[r][c] & 0xdf) == 0)
+ #define ttssend(x) if (x) tts_send(x, strlen(x))
diff --git a/app-accessibility/yasr/files/yasr-0.6.9-gettext018.patch b/app-accessibility/yasr/files/yasr-0.6.9-gettext018.patch
new file mode 100644
index 000000000000..26337dbc6735
--- /dev/null
+++ b/app-accessibility/yasr/files/yasr-0.6.9-gettext018.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.in b/configure.in
+index c26f577..d78e8b2 100644
+--- a/configure.in
++++ b/configure.in
+@@ -57,7 +57,7 @@ fi
+ changequote([,])dnl
+
+ AM_GNU_GETTEXT(external)
+-AM_GNU_GETTEXT_VERSION([0.17])
++AM_GNU_GETTEXT_VERSION([0.18.1])
+
+ AC_OUTPUT([ m4/Makefile
+ Makefile
diff --git a/app-accessibility/yasr/files/yasr-0.6.9-remove-m4.patch b/app-accessibility/yasr/files/yasr-0.6.9-remove-m4.patch
new file mode 100644
index 000000000000..fa05f0791fc2
--- /dev/null
+++ b/app-accessibility/yasr/files/yasr-0.6.9-remove-m4.patch
@@ -0,0 +1,29 @@
+diff -Naur yasr-0.6.9.orig/Makefile.am yasr-0.6.9/Makefile.am
+--- yasr-0.6.9.orig/Makefile.am 2008-02-02 06:44:05.000000000 -0600
++++ yasr-0.6.9/Makefile.am 2009-02-06 08:37:07.000000000 -0600
+@@ -7,7 +7,6 @@
+
+ SUBDIRS = \
+ $(yasr_DDIRS) \
+-m4 \
+ po
+
+ pkgdata_DATA = \
+@@ -25,4 +24,3 @@
+ README-fr \
+ README-ru
+
+-ACLOCAL_AMFLAGS = -I m4
+diff -Naur yasr-0.6.9.orig/configure.in yasr-0.6.9/configure.in
+--- yasr-0.6.9.orig/configure.in 2008-02-02 07:09:04.000000000 -0600
++++ yasr-0.6.9/configure.in 2009-02-06 08:36:43.000000000 -0600
+@@ -59,8 +59,7 @@
+ AM_GNU_GETTEXT(external)
+ AM_GNU_GETTEXT_VERSION([0.17])
+
+-AC_OUTPUT([ m4/Makefile
+-Makefile
++AC_OUTPUT([ Makefile
+ yasr/Makefile
+ acclogin/Makefile
+ po/Makefile.in
diff --git a/app-accessibility/yasr/metadata.xml b/app-accessibility/yasr/metadata.xml
new file mode 100644
index 000000000000..6e084ef16675
--- /dev/null
+++ b/app-accessibility/yasr/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <upstream>
+ <remote-id type="sourceforge">yasr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-accessibility/yasr/yasr-0.6.9-r1.ebuild b/app-accessibility/yasr/yasr-0.6.9-r1.ebuild
new file mode 100644
index 000000000000..e54176e6c935
--- /dev/null
+++ b/app-accessibility/yasr/yasr-0.6.9-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="general-purpose console screen reader"
+HOMEPAGE="http://yasr.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls"
+
+RDEPEND=""
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ local x=/usr/share/gettext/po/Makefile.in.in
+ [[ -e $x ]] && cp -f $x po/ #330879
+
+ epatch "${FILESDIR}"/${P}-automake113.patch \
+ "${FILESDIR}"/${P}-gettext018.patch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-remove-m4.patch
+
+ rm -r "${S}"/m4
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --datadir=/etc \
+ --disable-dependency-tracking \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README ChangeLog AUTHORS BUGS CREDITS
+ dosed \
+ 's:^\(synthesizer=emacspeak server\):#\1:
+ s:^\(synthesizer port=|/usr/local/bin/eflite\):#\1:
+ s:^#\(synthesizer=speech dispatcher\):\1:
+ s:^#\(synthesizer port=127.0.0.1.6560\):\1:' /etc/yasr/yasr.conf
+}
+
+pkg_postinst() {
+ elog
+ elog "Speech-dispatcher is configured as the default synthesizer for yasr."
+ elog "If this is not what you want, edit /etc/yasr/yasr.conf."
+}