summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-18 13:01:00 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-18 13:01:00 +0200
commit03fce5d8d3f59154efb1ac1052e5e7bc8b1dd0b7 (patch)
tree1a16255a92d4709171d09b1c7bc7735c7e1df2ac /app-accessibility
parentdev-cpp/glibmm: bump to 2.58.1 (diff)
downloadgentoo-03fce5d8d3f59154efb1ac1052e5e7bc8b1dd0b7.tar.gz
gentoo-03fce5d8d3f59154efb1ac1052e5e7bc8b1dd0b7.tar.bz2
gentoo-03fce5d8d3f59154efb1ac1052e5e7bc8b1dd0b7.zip
app-accessibility/orca: bump to 3.30.2
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/orca/Manifest1
-rw-r--r--app-accessibility/orca/orca-3.30.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index 154421b7063a..f857165dc086 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,3 +1,4 @@
DIST orca-3.24.0.tar.xz 2391740 BLAKE2B 1f294bc8e1c593690c511f0d7d660230c420b33de59c8b1e78ee8d7b16f973b9fff9ce4d656de7202ffd5789ae3604d030c442e8c35eecfd5c5dca058031e996 SHA512 9aa65b534f69bb4a1b800e715776416843ac3756ec1267feca3c66476e34e54f6744f70c0f8ac8868a009d38b6cc165267268491a9ad29ebbd3601dba09d424c
DIST orca-3.26.0.tar.xz 2407368 BLAKE2B e04a891a2f2478b5b5f556a423c073f8c64de78d1f744d41d292cd783edc2ba0e57824ba3afb1f1b58f62503a204003d97e1fb652df307f34ae6838bce44389c SHA512 ca3a60b36d9528cf424e01d7a1aad75a8e14e46a6c93330b8e439bd44832dbc44897657b8da3c583501ce8c835f589209f1b3969ab110766cb1dc099defd2445
DIST orca-3.28.2.tar.xz 2460112 BLAKE2B 7c577f639c7a37e5bae755bab32b753d0f2a9eef49872a9b0f3805ad33d8dd8ded7bdfda8239662eec87dde1b0d935634628709fa18e0b0db223550ee478ad59 SHA512 3a93c39f9245890d134fa96e58bdfdb273600730be6fedd8590628cf8b1740a6caa7c4fb180c1da156e179b6e0cc352f6f5aacfa8eaed3e306f399bd1fe3cc43
+DIST orca-3.30.2.tar.xz 2493112 BLAKE2B 06ac902f67c66d5098be1829aa7cb7a160663a3a713d407a5245a95215c309f3b374937e4b70acbf9750f6e0e270ed8ab5516ca3cb6b0a19f347ee72a01a325b SHA512 146a132ce06f7f36d6d9397c507ea767be5df6c47a5c7485c35c325868ebc0b3ff7b3653572be82f6d5ed937033cd6d68a08700056a63e5691aed4c9171b3485
diff --git a/app-accessibility/orca/orca-3.30.2.ebuild b/app-accessibility/orca/orca-3.30.2.ebuild
new file mode 100644
index 000000000000..3a12f54a432c
--- /dev/null
+++ b/app-accessibility/orca/orca-3.30.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="threads"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-atk-2.30:2
+ >=app-accessibility/at-spi2-core-2.30:2[introspection]
+ >=dev-libs/atk-2.30
+ >=dev-libs/glib-2.28:2
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ braille? (
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ dev-libs/atk[introspection]
+ >=dev-python/pyatspi-2.30[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}