summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-06-06 13:56:28 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-06 14:49:06 -0700
commit321c241825d7305e216805b0531d339c444b7c1f (patch)
tree6fb2678ceb0c5ee84e0ef9455c08eb2aa559c11e /app-accessibility
parentsys-boot/lilo: Fix bugs #377427 and #473620 (diff)
downloadgentoo-321c241825d7305e216805b0531d339c444b7c1f.tar.gz
gentoo-321c241825d7305e216805b0531d339c444b7c1f.tar.bz2
gentoo-321c241825d7305e216805b0531d339c444b7c1f.zip
app-accessibility/at-spi2-core: Version bump to 2.40.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/at-spi2-core/Manifest1
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.40.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-accessibility/at-spi2-core/Manifest b/app-accessibility/at-spi2-core/Manifest
index 4252929f87b8..8cf631a27fda 100644
--- a/app-accessibility/at-spi2-core/Manifest
+++ b/app-accessibility/at-spi2-core/Manifest
@@ -1 +1,2 @@
DIST at-spi2-core-2.40.1.tar.xz 197064 BLAKE2B dfa19413e6688678fcc0c0ed76d0fca0d5de5039c9b1e42dc10c9c387c0cbffb3c6a38570f9e74c343fa86310f2c3f6fcf0e311c57d11b5adeac5faf7bdf9630 SHA512 fcb73e78a85db9b982ae10d8c968c7732079832877fa0214c30a04b9e27910448c3f5456b8628ed4a3d4dbd59037c8c206916ad1462ca5c7a44409a702096b14
+DIST at-spi2-core-2.40.2.tar.xz 197476 BLAKE2B a3b6f1edb7beace2a54cc651f8bf5d002009a3d2791306f2b0a33c351c68d04e0a1003ab11f215333d498c50d17139b978e7f232df802f6c620bbe31997a8e1c SHA512 854fbba39064ba4b1d9728fc4943e811f0a9557f1096f32d7a6486bcb6c73379ab84c5fb8ce5288bf4dab1d1cd3e0664c492977450d4da503ce4b08abfc75fd9
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.40.2.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.40.2.ebuild
new file mode 100644
index 000000000000..595c3594907e
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.40.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson-multilib systemd virtualx xdg
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+IUSE="X gtk-doc +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.62:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54.0:= )
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.25
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
+ "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dsystemd_user_dir="$(systemd_get_userunitdir)"
+ $(meson_native_use_bool gtk-doc docs)
+ -Dintrospection=$(multilib_native_usex introspection)
+ -Dx11=$(usex X)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx dbus-run-session meson test -C "${BUILD_DIR}"
+}