summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-29 22:41:29 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-29 23:32:50 +0100
commit3deb978bc9d01023b1acddc300c71ab09a6a35bb (patch)
treec137fdf0cfdb4b49ada28fc18e8e49e9268682ed /app-accessibility
parentapp-accessibility/festival-hts: Port to EAPI 6 (diff)
downloadgentoo-3deb978bc9d01023b1acddc300c71ab09a6a35bb.tar.gz
gentoo-3deb978bc9d01023b1acddc300c71ab09a6a35bb.tar.bz2
gentoo-3deb978bc9d01023b1acddc300c71ab09a6a35bb.zip
app-accessibility/sphinx2: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/sphinx2/files/sphinx2-0.6-as-needed.patch35
-rw-r--r--app-accessibility/sphinx2/sphinx2-0.6.ebuild29
2 files changed, 41 insertions, 23 deletions
diff --git a/app-accessibility/sphinx2/files/sphinx2-0.6-as-needed.patch b/app-accessibility/sphinx2/files/sphinx2-0.6-as-needed.patch
index 0520d4d987e4..f647ab35142c 100644
--- a/app-accessibility/sphinx2/files/sphinx2-0.6-as-needed.patch
+++ b/app-accessibility/sphinx2/files/sphinx2-0.6-as-needed.patch
@@ -1,20 +1,17 @@
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 05a4f8a..23d0309 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -1,5 +1,5 @@
--SUBDIRS = libsphinx2 \
-- libsphinx2fe \
-+SUBDIRS = libsphinx2fe \
- libsphinx2ad \
-+ libsphinx2 \
- examples
+--- a/configure.in
++++ b/configure.in
+@@ -1,7 +1,7 @@
+ dnl Welcome to the Sphinx-2 automated build system.
+ dnl try not to hurt yourself ;)
+
+-AC_INIT(configure.in)
++AC_INIT(configure.ac)
+ AM_INIT_AUTOMAKE(sphinx2,0.6)
-diff --git a/src/libsphinx2/Makefile.am b/src/libsphinx2/Makefile.am
-index 66f0ac3..537381c 100644
+ CFLAGS=${CFLAGS:--g -O2 -Wall}
--- a/src/libsphinx2/Makefile.am
+++ b/src/libsphinx2/Makefile.am
-@@ -88,7 +88,7 @@ libsphinx2_la_SOURCES = \
+@@ -88,7 +88,7 @@
word_fsg.c
@@ -23,3 +20,13 @@ index 66f0ac3..537381c 100644
# hjf@cs.brown.edu - Added for Solaris build
# LDADD = -L/usr/demo/SOUND/lib/ -laudio
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,5 +1,5 @@
+-SUBDIRS = libsphinx2 \
+- libsphinx2fe \
++SUBDIRS = libsphinx2fe \
+ libsphinx2ad \
++ libsphinx2 \
+ examples
+
diff --git a/app-accessibility/sphinx2/sphinx2-0.6.ebuild b/app-accessibility/sphinx2/sphinx2-0.6.ebuild
index d2fda0b62aef..0ca32c0a2170 100644
--- a/app-accessibility/sphinx2/sphinx2-0.6.ebuild
+++ b/app-accessibility/sphinx2/sphinx2-0.6.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
-inherit autotools eutils
+inherit autotools
MY_P=${P/_/}
-S=${WORKDIR}/${MY_P}
DESCRIPTION="CMU Speech Recognition-engine"
HOMEPAGE="http://fife.speech.cs.cmu.edu/sphinx/"
@@ -15,15 +14,27 @@ SRC_URI="mirror://sourceforge/cmusphinx/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
+IUSE="static-libs"
+
+S=${WORKDIR}/${MY_P}
+PATCHES=( "${FILESDIR}"/${P}-as-needed.patch )
src_prepare() {
- epatch "${FILESDIR}"/${P}-as-needed.patch
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README doc/README.bin doc/README.lib doc/SCHMM_format doc/filler.dict doc/phoneset doc/phoneset-old
- dohtml doc/phoneset_s2.html doc/sphinx2.html
+ HTML_DOCS=( doc/{phoneset_s2,sphinx2}.html )
+ default
+ dodoc doc/{README.{bin,lib},SCHMM_format,filler.dict,phoneset{,-old}}
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
}