summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-24 19:10:06 -0700
committerMatt Turner <mattst88@gentoo.org>2020-03-24 19:20:17 -0700
commitb1ae4343bc308b21bf03a050c3c9ca3647b8f01e (patch)
tree10a3b87a383f0824c684c83636046926a82f6281 /app-accessibility
parentdev-libs/appstream-glib: Version bump to 0.7.17 (diff)
downloadgentoo-b1ae4343bc308b21bf03a050c3c9ca3647b8f01e.tar.gz
gentoo-b1ae4343bc308b21bf03a050c3c9ca3647b8f01e.tar.bz2
gentoo-b1ae4343bc308b21bf03a050c3c9ca3647b8f01e.zip
app-accessibility/at-spi2-core: Version bump to 2.36.0
Run tests under dbus-run-session. Closes: https://bugs.gentoo.org/680480 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/at-spi2-core/Manifest1
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.36.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-accessibility/at-spi2-core/Manifest b/app-accessibility/at-spi2-core/Manifest
index a454af54eeda..56a3385f531d 100644
--- a/app-accessibility/at-spi2-core/Manifest
+++ b/app-accessibility/at-spi2-core/Manifest
@@ -1,2 +1,3 @@
DIST at-spi2-core-2.32.1.tar.xz 188952 BLAKE2B a12e234b19a38b0fcffbabb8430ef49dc538b38831cc22bbafc7f5d499082007909a82e785184d052f3a62853474cbc4838125540026a6d0e2ac2181e98a6a4c SHA512 cec6ea1426b25d9738c5c401a1038b39e04b1e989b7ef8e02590d117b35cfb253b260cc6e41b09e10e007801fedcb7702c48ba7f3a0c7b6c1f16edd4e8ad0cca
DIST at-spi2-core-2.34.0.tar.xz 186736 BLAKE2B 6210ef0254760f1ef6e9c9124680f604864e24228650d4be1026dc73ce0ec5d10eec5e9958a98f0970e1292e4fc3935c8379278b10c633c87da5eb3960b94670 SHA512 99f6773e29fb5fcb339cbe5b23133dab78bc52e3c46a1d5bd748788c48345223f1def5078ac48e58756a7692459b177b0e26dc8059898a5ccac56ceb495b7de8
+DIST at-spi2-core-2.36.0.tar.xz 186824 BLAKE2B a713d413c1ff291bf82107f6bedccd24d5e9e5312145ac7c4783fcf8366238c2d5cc4ba442fb0c71286abcd695b516861387f76c22ff9e427bd19b99bb7d5d3c SHA512 f45d7e68bfcd9b93cebc47e30febce1ae6a4d9df2fbc9d5bdc25babb123c922d0f9a229485770b2f6ed386178144c20486fa3e46195041ea65a54ab019b1cbb6
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.36.0.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.36.0.ebuild
new file mode 100644
index 000000000000..67e6586b1007
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.36.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson multilib-minimal systemd virtualx xdg
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+IUSE="X gtk-doc +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+RDEPEND="
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.36:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54.0:= )
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-util/meson-0.50.0
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.25
+ app-text/docbook-xml-dtd:4.3 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+PATCHES=(
+ # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
+ "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dsystemd_user_dir="$(systemd_get_userunitdir)"
+ -Ddocs=$(multilib_native_usex gtk-doc true false)
+ -Dintrospection=$(multilib_native_usex introspection)
+ -Dx11=$(usex X)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ virtx dbus-run-session meson test -C "${BUILD_DIR}"
+}
+
+multilib_src_install() {
+ meson_src_install
+}