summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-02-19 18:51:01 -0800
committerMatt Turner <mattst88@gentoo.org>2020-02-19 18:54:39 -0800
commite4c33ebe587a88c4a85c0c611cada9df3895c3c0 (patch)
tree5ddc183531165b3c8b5c584bfcc4875df44ebf57 /app-accessibility
parentsys-kernel/gentoo-sources: Linux patch 5.4.21 (diff)
downloadgentoo-e4c33ebe587a88c4a85c0c611cada9df3895c3c0.tar.gz
gentoo-e4c33ebe587a88c4a85c0c611cada9df3895c3c0.tar.bz2
gentoo-e4c33ebe587a88c4a85c0c611cada9df3895c3c0.zip
app-accessibility/flite: Drop IUSE=static-libs
Broken and unneeded. Closes: https://bugs.gentoo.org/538712 Closes: https://bugs.gentoo.org/539556 Closes: https://bugs.gentoo.org/635230 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/flite/flite-1.4-r4.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/app-accessibility/flite/flite-1.4-r4.ebuild b/app-accessibility/flite/flite-1.4-r4.ebuild
index 5e652f73704d..9164855c02bd 100644
--- a/app-accessibility/flite/flite-1.4-r4.ebuild
+++ b/app-accessibility/flite/flite-1.4-r4.ebuild
@@ -11,7 +11,7 @@ SRC_URI=" http://www.speech.cs.cmu.edu/${PN}/packed/${P}/${P}-release.tar.bz2"
LICENSE="BSD freetts public-domain regexp-UofT BSD-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ppc ppc64 sparc x86"
-IUSE="alsa oss static-libs"
+IUSE="alsa oss"
DEPEND="alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )"
RDEPEND="${DEPEND}"
@@ -49,12 +49,10 @@ src_prepare() {
}
multilib_src_configure() {
- local myconf=()
- if ! use static-libs; then
- myconf+=( --enable-shared )
- fi
- myconf+=( --with-audio=$(get_audio) )
-
+ local myconf=(
+ --enable-shared
+ --with-audio=$(get_audio)
+ )
econf "${myconf[@]}"
}
@@ -65,9 +63,7 @@ multilib_src_compile() {
multilib_src_install_all() {
dodoc ACKNOWLEDGEMENTS README
- if ! use static-libs; then
- find "${ED}" -name '*.a' ! -name '*.dll.a' -delete || die
- fi
+ find "${ED}" -name '*.a' ! -name '*.dll.a' -delete || die
}
pkg_postinst() {