summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-09-07 16:55:17 +0200
committerPacho Ramos <pacho@gentoo.org>2021-09-07 17:08:07 +0200
commit7d181b751d9bc08cbe075b539db3f12391295110 (patch)
treeb05c18e3487873a4aa7746433dd786bfb0d1683c /app-admin/abrt
parentmedia-libs/harfbuzz: Removed old (diff)
downloadgentoo-7d181b751d9bc08cbe075b539db3f12391295110.tar.gz
gentoo-7d181b751d9bc08cbe075b539db3f12391295110.tar.bz2
gentoo-7d181b751d9bc08cbe075b539db3f12391295110.zip
app-admin/abrt: Bump to 2.14.6
Closes: https://bugs.gentoo.org/638586 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-admin/abrt')
-rw-r--r--app-admin/abrt/Manifest1
-rw-r--r--app-admin/abrt/abrt-2.14.6.ebuild126
2 files changed, 127 insertions, 0 deletions
diff --git a/app-admin/abrt/Manifest b/app-admin/abrt/Manifest
index 2062051ec43d..616025676b5b 100644
--- a/app-admin/abrt/Manifest
+++ b/app-admin/abrt/Manifest
@@ -1,2 +1,3 @@
DIST abrt-2.14.2.tar.gz 6113632 BLAKE2B 904ec2ca4c3aa70b62573ca2730742689f4446c1e5f04bfb6dc4267a4a9a6d44ef8c2b6e82c1e0aba04876b400c3a965a879da65bbff7ec729846f1b5c28cdf9 SHA512 82ba10cb151b4585024e3dfc626f46a7d967797e0375158cd76355c4f6a66c59578cc7b41bc5d5aaa3e694b3653b8658650df458676225660cfe95ec318c6886
DIST abrt-2.14.5.tar.gz 6056105 BLAKE2B 22e797a431237bd3d4ef6f2467842c5f08e2ef3ca51e7857e3c55e45ed93a9499843fe40b081c70affb5def8f2cfe78d61e865c51c969fb2c9936225bdfe4996 SHA512 a8672735c6d3263ddff006e6e186d9b71e6d9375a8c909c2a85bbbf736a6687b6fe4aa74640a07664f14fd886895a86babf41218a8c2365d6fccd347630ccc9e
+DIST abrt-2.14.6.tar.gz 6057661 BLAKE2B 2ef74203181c89818f283a801c4a1a0f22a01c92ca2415d245dc180ee721b3e29cb75c95e45d738f88b6bbf339fe8bef4e499ab6fecad33399dc8a5af8f98d4c SHA512 eb1ba2f624d51eeccd203bb23060493347f5a9142fad7d0570d46134071d870a9c66b4fbfb8210e7d6f87c0c039f31eb486d18a36b10fba318e2180aa09df9fe
diff --git a/app-admin/abrt/abrt-2.14.6.ebuild b/app-admin/abrt/abrt-2.14.6.ebuild
new file mode 100644
index 000000000000..88a7e4e15587
--- /dev/null
+++ b/app-admin/abrt/abrt-2.14.6.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit autotools python-single-r1 tmpfiles xdg
+
+DESCRIPTION="Automatic bug detection and reporting tool"
+HOMEPAGE="https://github.com/abrt/abrt/wiki/ABRT-Project https://github.com/abrt/abrt"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="selinux test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.56:2
+ >=dev-libs/libreport-2.13.0[gtk,python]
+ dev-libs/libxml2:2
+ >=gnome-base/gsettings-desktop-schemas-3.15.1
+ net-libs/libsoup:2.4
+ sys-apps/dbus
+ sys-apps/systemd:0=
+ sys-auth/polkit
+ sys-libs/libcap
+ sys-fs/inotify-tools
+ x11-libs/gtk+:3
+"
+RDEPEND="${DEPEND}
+ acct-user/abrt
+ acct-group/abrt
+ app-arch/cpio
+ app-arch/rpm[python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/elfutils
+ dev-libs/json-c:0=
+ sys-apps/util-linux
+ >=sys-devel/gdb-7
+ $(python_gen_cond_dep '
+ dev-libs/satyr[${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ $(python_gen_cond_dep 'dev-python/python-systemd[${PYTHON_USEDEP}]')
+ test? (
+ $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
+ )
+ app-text/asciidoc
+ app-text/xmlto
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang .
+ default
+
+ # Install under proper directory
+ sed -i -e 's:dbusabrtdocdir = ${datadir}/doc/abrt-dbus-${VERSION}/html:dbusabrtdocdir = ${datadir}/doc/${PF}/html:' doc/problems-service/Makefile.am || die
+
+ # Ensure this works for systems with and without /usr merge
+ sed -i -e "s:/usr/bin/bash:$(which bash):" init-scripts/abrtd.service || die
+
+ # Fix hardcoded "pytest-3"
+ sed -i -e "s:pytest-3:pytest:" \
+ configure.ac src/python-problem/tests/Makefile.am src/cli/test || die
+
+ # pyhook test is sensitive to the format of python's error messages, and
+ # fails with certain python versions
+ sed -e '/pyhook.at/ d' \
+ -i tests/Makefile.* tests/testsuite.at || die "sed remove pyhook tests failed"
+ ./gen-version || die # Needed to be run before autoreconf
+ eautoreconf
+}
+
+src_configure() {
+ myeconfargs=(
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --localstatedir="${EPREFIX}/var"
+ --without-bodhi
+ # package breaks due to not finding libreport-web with bodhi plugin enabled
+ --without-rpm
+ $(usex selinux "" "--without-selinux")
+ --with-python3
+ --without-pythondoc
+ # package breaks due to no sphinx-build-3
+ $(use_with test pythontests)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ python_optimize
+
+ # /var/spool/abrt is created by dev-libs/libreport
+ diropts -m 700 -o abrt -g abrt
+ keepdir /var/spool/abrt-upload
+
+ find "${D}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}/${PN}-2.0.12-r1-init" abrt
+ newconfd "${FILESDIR}/${PN}-2.0.12-r1-conf" abrt
+
+ # Drop empy dirs, handled by tmpfiles
+ rm -r "${ED}"/var/run/ || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ tmpfiles_process abrt.conf
+}