summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-12-12 19:15:02 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-12-12 19:15:10 -0600
commitd8acc27f1e8a18edd3b68eb0a08dc9b583c0094d (patch)
tree087d9268299dd433f745fa4e8107ab81000b6e51 /app-admin/ansible-base
parentprofiles/package.mask: mask =sys-libs/libcap-ng-0.8.2 (diff)
downloadgentoo-d8acc27f1e8a18edd3b68eb0a08dc9b583c0094d.tar.gz
gentoo-d8acc27f1e8a18edd3b68eb0a08dc9b583c0094d.tar.bz2
gentoo-d8acc27f1e8a18edd3b68eb0a08dc9b583c0094d.zip
app-admin/ansible-base: remove doc flag due to upstream bug
https://github.com/ansible/ansible/issues/71395 Closes: https://bugs.gentoo.org/747316 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/ansible-base')
-rw-r--r--app-admin/ansible-base/ansible-base-2.10.2.ebuild18
-rw-r--r--app-admin/ansible-base/ansible-base-2.10.3.ebuild18
2 files changed, 4 insertions, 32 deletions
diff --git a/app-admin/ansible-base/ansible-base-2.10.2.ebuild b/app-admin/ansible-base/ansible-base-2.10.2.ebuild
index 6843d55c4702..b24b734cb988 100644
--- a/app-admin/ansible-base/ansible-base-2.10.2.ebuild
+++ b/app-admin/ansible-base/ansible-base-2.10.2.ebuild
@@ -14,8 +14,9 @@ SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~ppc64 x86 ~x64-macos"
-IUSE="doc test"
+IUSE="test"
RESTRICT="test"
+# doc removed due to https://github.com/ansible/ansible/issues/71395
RDEPEND="
dev-python/paramiko[${PYTHON_USEDEP}]
@@ -36,11 +37,6 @@ DEPEND="
!<app-admin/ansible-2.10
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
- )
test? (
${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
@@ -57,21 +53,11 @@ python_compile() {
distutils-r1_python_compile
}
-python_compile_all() {
- if use doc; then
- cd docs/docsite || die
- export CPUS=4
- emake -f Makefile.sphinx html
- fi
-}
-
python_test() {
nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
}
python_install_all() {
- use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
distutils-r1_python_install_all
-
dodoc -r examples
}
diff --git a/app-admin/ansible-base/ansible-base-2.10.3.ebuild b/app-admin/ansible-base/ansible-base-2.10.3.ebuild
index 020fba19e139..5dbedc04ecfe 100644
--- a/app-admin/ansible-base/ansible-base-2.10.3.ebuild
+++ b/app-admin/ansible-base/ansible-base-2.10.3.ebuild
@@ -14,8 +14,9 @@ SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86 ~x64-macos"
-IUSE="doc test"
+IUSE="test"
RESTRICT="test"
+# doc removed due to https://github.com/ansible/ansible/issues/71395
RDEPEND="
dev-python/paramiko[${PYTHON_USEDEP}]
@@ -36,11 +37,6 @@ DEPEND="
!<app-admin/ansible-2.10
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
- )
test? (
${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
@@ -57,21 +53,11 @@ python_compile() {
distutils-r1_python_compile
}
-python_compile_all() {
- if use doc; then
- cd docs/docsite || die
- export CPUS=4
- emake -f Makefile.sphinx html
- fi
-}
-
python_test() {
nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
}
python_install_all() {
- use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
distutils-r1_python_install_all
-
dodoc -r examples
}