summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-06-25 12:59:20 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-06-25 12:59:20 -0500
commit93c7ef79b85136209b61918df7100c41705d4181 (patch)
treed80af2adb4a97edabdfcbe6019e0c7cb5bb07b35 /app-admin/ansible/ansible-4.6.0.ebuild
parentRevert "app-admin/ansible-base: 2.11.7 cleanup" (diff)
downloadgentoo-93c7ef79b85136209b61918df7100c41705d4181.tar.gz
gentoo-93c7ef79b85136209b61918df7100c41705d4181.tar.bz2
gentoo-93c7ef79b85136209b61918df7100c41705d4181.zip
Revert "app-admin/ansible: 4.6.0 cleanup"
This reverts commit 84c35a35d5cdb4c74339b3be2e165b7d0d507c17. Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/ansible/ansible-4.6.0.ebuild')
-rw-r--r--app-admin/ansible/ansible-4.6.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/ansible/ansible-4.6.0.ebuild b/app-admin/ansible/ansible-4.6.0.ebuild
new file mode 100644
index 000000000000..d96231433bb4
--- /dev/null
+++ b/app-admin/ansible/ansible-4.6.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-base-2.11.1
+ <app-admin/ansible-base-2.12"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}