summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-09-18 13:59:00 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-09-18 15:03:45 +0200
commite4c88af1916f3542f51e3f79c87500406c446b06 (patch)
tree986add5a1f5fb3a0f3ed90d82cda15163c1ca23c /app-admin/apache-tools/apache-tools-2.2.34.ebuild
parentdev-perl/XML-Stream: Fix ebuild.badheader (diff)
downloadgentoo-e4c88af1916f3542f51e3f79c87500406c446b06.tar.gz
gentoo-e4c88af1916f3542f51e3f79c87500406c446b06.tar.bz2
gentoo-e4c88af1916f3542f51e3f79c87500406c446b06.zip
app-admin/apache-tools: Bump to v2.2.34
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-admin/apache-tools/apache-tools-2.2.34.ebuild')
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.34.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/app-admin/apache-tools/apache-tools-2.2.34.ebuild b/app-admin/apache-tools/apache-tools-2.2.34.ebuild
new file mode 100644
index 000000000000..0fe392617c23
--- /dev/null
+++ b/app-admin/apache-tools/apache-tools-2.2.34.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic eutils
+
+DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+HOMEPAGE="https://httpd.apache.org/"
+SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl"
+RESTRICT="test"
+
+RDEPEND="=dev-libs/apr-1*
+ =dev-libs/apr-util-1*
+ dev-libs/expat
+ dev-libs/libpcre
+ kernel_linux? ( sys-apps/util-linux )
+ ssl? ( dev-libs/openssl:0= )
+ !<www-servers/apache-2.2.4"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S="${WORKDIR}/httpd-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.2.20-Makefile.patch"
+)
+
+src_configure() {
+ # Brain dead check.
+ tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
+
+ # Instead of filtering --as-needed (bug #128505), append --no-as-needed
+ append-ldflags $(no-as-needed)
+
+ # econf overwrites the stuff from config.layout.
+ econf \
+ --sbindir=/usr/sbin \
+ --with-z=/usr \
+ --with-apr=/usr \
+ --with-apr-util=/usr \
+ --with-pcre=/usr \
+ $(use_enable ssl) \
+ $(usex ssl '--with-ssl=/usr' '')
+}
+
+src_compile() {
+ cd support || die
+ emake
+}
+
+src_install () {
+ cd support || die
+
+ make DESTDIR="${D}" install || die
+
+ # install manpages
+ doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
+ "${S}"/docs/man/{htcacheclean,rotatelogs,ab,logresolve}.8
+
+ # Providing compatiblity symlinks for #177697 (which we'll stop to install
+ # at some point).
+ pushd "${D}"/usr/sbin/ >/dev/null || die
+ for i in *; do
+ dosym /usr/sbin/${i} /usr/sbin/${i}2
+ done
+ popd >/dev/null || die
+
+ # Provide a symlink for ab-ssl
+ if use ssl; then
+ dosym /usr/sbin/ab /usr/sbin/ab-ssl
+ dosym /usr/sbin/ab /usr/sbin/ab2-ssl
+ fi
+
+ # make htpasswd accessible for non-root users
+ dosym /usr/sbin/htpasswd /usr/bin/htpasswd
+ dosym /usr/sbin/htdigest /usr/bin/htdigest
+
+ dodoc "${S}"/CHANGES
+}