summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-29 06:10:24 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-29 06:58:34 +0200
commitcc97648e60cd72e2472ad3faa8a5b8eea45e8459 (patch)
treea60b585cb595adb8e5f37769504a032c643f836b /app-admin/awscli
parentdev-python/boto3: Bump to 1.26.123 (diff)
downloadgentoo-cc97648e60cd72e2472ad3faa8a5b8eea45e8459.tar.gz
gentoo-cc97648e60cd72e2472ad3faa8a5b8eea45e8459.tar.bz2
gentoo-cc97648e60cd72e2472ad3faa8a5b8eea45e8459.zip
app-admin/awscli: Bump to 1.27.123
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.123.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 9f9e74e0c1fa..92cf9b370c27 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST aws-cli-1.27.119.gh.tar.gz 2411159 BLAKE2B 7730da312c27cb99bf8a9b135164fe89
DIST aws-cli-1.27.120.gh.tar.gz 2412302 BLAKE2B d5af6c029452246abc8296fcf7da7edbc5b68852c4f1a162dcce91ea1fd42ee036f49ad9c7cf692e860e8c29eb3107d3befdbf23833ef47604fb43d836dd86ec SHA512 07a10480fd41cb81867a6a93d3fdfb6f3687e82790711c2e30a72155ca6083e9d6c584c6afcfb57b47aff2300ba42557471ffcc4c1b6e8d50ea21f5fd096c042
DIST aws-cli-1.27.121.gh.tar.gz 2412265 BLAKE2B c622b4af462578c928b0b261ebdc300b841440875b8208240be6bf56b7a7f28d58434dc9c5cd41581befebc20fc0e224db52474af23e94e6a7e92e113e93bf99 SHA512 d39e2b4b0cedf1d622877584decfa5a38624cd238007343737087d2781d1505e2858337c508a4578cfc8d568412e3f92f38f80ae09f3a39a8cbb34034d474763
DIST aws-cli-1.27.122.gh.tar.gz 2413914 BLAKE2B e8b1122119549cb7e5700b6d0617169885a6565cac6a6b8d14a1fde1ff6da6b32c1fa4cb183959ea57700e9ca014872c6e50b8ba76cde2628d5f6c2cbe270717 SHA512 59686acaa568a38deab45399506c767e3dae02193f79a2ee2cbd129bd37826fa24d4ad5652ae2e9a52d7969cefd3e847b9fcfa2304da19d6fb976fd8f79e68e4
+DIST aws-cli-1.27.123.gh.tar.gz 2414392 BLAKE2B 4df3e98062e61931efc59168eb6dbe6b50f2bd50ef6d5d810bf2d98f08058f69c8965726662f90e8289e94408e916e700acc2d62512d3b3033210eb615bbb8c4 SHA512 bfe6fe1a2fd9209090957faef600b40acd7c4bbf9304089a2844ac736d782a0c53687dd1073faf9e05c8e23c6dd1b6d7930e009dc0ea7765000489130d2a5410
diff --git a/app-admin/awscli/awscli-1.27.123.ebuild b/app-admin/awscli/awscli-1.27.123.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.123.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}