summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-05-19 12:46:02 +0200
committerJohannes Huber <johu@gentoo.org>2018-05-19 12:47:44 +0200
commit91ce9f03eecb36bd2d4b138cb506dedb5612c458 (patch)
tree7a334179c75c8cc2413bb3115ecab9cac546a419 /app-admin/calamares
parentsys-fs/multipath-tools: keyworded 0.6.4-r1 for ia64, bug #655730 (diff)
downloadgentoo-91ce9f03eecb36bd2d4b138cb506dedb5612c458.tar.gz
gentoo-91ce9f03eecb36bd2d4b138cb506dedb5612c458.tar.bz2
gentoo-91ce9f03eecb36bd2d4b138cb506dedb5612c458.zip
app-admin/calamares: Version bump 3.2.0
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'app-admin/calamares')
-rw-r--r--app-admin/calamares/Manifest1
-rw-r--r--app-admin/calamares/calamares-3.2.0.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/app-admin/calamares/Manifest b/app-admin/calamares/Manifest
index 21c218a2d05c..57c83e0098ed 100644
--- a/app-admin/calamares/Manifest
+++ b/app-admin/calamares/Manifest
@@ -1 +1,2 @@
DIST calamares-3.1.13.tar.gz 2279516 BLAKE2B ff2c81e81086d53c205c25dbdb7e8b1b60f5f10c979e9afd85c02426cd38037c6fbbf76e21fa5fb152ea9bf1c47658563ba5b2fb7e84b4e2734d6269584315df SHA512 451e04fe41448976e612b2a682cf38ed2683b490bb195ba82ad97d47dfd3eb808f8c25251be00104e3f3b4086ab37be462034bbd2866e64536e90f7ebcfb0d7a
+DIST calamares-3.2.0.tar.gz 2488863 BLAKE2B 6941cdd7eb381a6ee4f7bc2628605ee5a670de0d839b5797cec930737ec5fc09e214c484c2e8398ab2f12669bbc64768d5ee20b2aa1adae799fb96373a0b07df SHA512 0b502749ace48ce56f2bb364d265c5b9197cca2b27115663f928cb58d02ba43e93b80b5022053bca5899ce6ee35146992157408fc5af017da6d61abdcdbc4e1d
diff --git a/app-admin/calamares/calamares-3.2.0.ebuild b/app-admin/calamares/calamares-3.2.0.ebuild
new file mode 100644
index 000000000000..a0864c5ac076
--- /dev/null
+++ b/app-admin/calamares/calamares-3.2.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_5,3_6} )
+inherit kde5 python-r1
+
+DESCRIPTION="Distribution-independent installer framework"
+HOMEPAGE="https://calamares.io"
+if [[ ${KDE_BUILD_TYPE} == live ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+IUSE="+networkmanager pythonqt +upower"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-cpp/yaml-cpp:=
+ >=dev-libs/boost-1.55:=[${PYTHON_USEDEP}]
+ dev-libs/libpwquality[${PYTHON_USEDEP}]
+ sys-apps/dbus
+ sys-apps/dmidecode
+ sys-auth/polkit-qt[qt5(+)]
+ >=sys-libs/kpmcore-3.0.3:5=
+ pythonqt? ( >=dev-python/PythonQt-3.1:=[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="${DEPEND}
+ app-admin/sudo
+ dev-libs/libatasmart
+ net-misc/rsync
+ >=sys-block/parted-3.0
+ || ( sys-boot/grub:2 sys-boot/systemd-boot )
+ sys-boot/os-prober
+ sys-fs/squashfs-tools
+ virtual/udev
+ networkmanager? ( net-misc/networkmanager )
+ upower? ( sys-power/upower )
+"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ python_setup
+ export PYTHON_INCLUDE_DIRS="$(python_get_includedir)" \
+ PYTHON_INCLUDE_PATH="$(python_get_library_path)"\
+ PYTHON_CFLAGS="$(python_get_CFLAGS)"\
+ PYTHON_LIBS="$(python_get_LIBS)"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWEBVIEW_FORCE_WEBKIT=OFF
+ -DWITH_PYTHONQT=$(usex pythonqt)
+ )
+
+ kde5_src_configure
+ sed -i -e 's:pkexec /usr/bin/calamares:calamares-pkexec:' "${S}"/calamares.desktop
+ sed -i -e 's:Icon=calamares:Icon=drive-harddisk:' "${S}"/calamares.desktop
+}
+
+src_install() {
+ kde5_src_install
+ dobin "${FILESDIR}"/calamares-pkexec
+}