summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-23 12:23:54 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-23 12:23:54 +0100
commit58535ab628a705399ffd2c1cbc5f11f7e3950e2c (patch)
tree9fd3ced37c165d3d5a068d044f792597bb811d7d /app-admin/cdist/cdist-6.9.4.ebuild
parentsci-electronics/klayout: Stable on amd64 (diff)
downloadgentoo-58535ab628a705399ffd2c1cbc5f11f7e3950e2c.tar.gz
gentoo-58535ab628a705399ffd2c1cbc5f11f7e3950e2c.tar.bz2
gentoo-58535ab628a705399ffd2c1cbc5f11f7e3950e2c.zip
app-admin/cdist: Bump to 6.9.4
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-admin/cdist/cdist-6.9.4.ebuild')
-rw-r--r--app-admin/cdist/cdist-6.9.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/cdist/cdist-6.9.4.ebuild b/app-admin/cdist/cdist-6.9.4.ebuild
new file mode 100644
index 000000000000..7fb25712179a
--- /dev/null
+++ b/app-admin/cdist/cdist-6.9.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="A usable configuration management system"
+HOMEPAGE="https://www.cdi.st/ https://code.ungleich.ch/ungleich-public/cdist"
+SRC_URI="https://code.ungleich.ch/ungleich-public/cdist/-/archive/${PV}/cdist-${PV}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_sphinx docs/src dev-python/sphinx_rtd_theme
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ echo "VERSION='${PV}'" > cdist/version.py || die
+
+ distutils-r1_python_prepare_all
+}