summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaak Ristioja <jaak@ristioja.ee>2020-04-29 12:00:59 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-04-30 14:59:54 +0300
commit95dbbb03abae1ed4a2f92b9aed9a75bf55e8943f (patch)
tree9e7d3ed58f245f350c472739e3a3dd1fb461d06e /app-admin/cdist
parentdev-python/python-distutils-extra: Add a missing dep on intltool (diff)
downloadgentoo-95dbbb03abae1ed4a2f92b9aed9a75bf55e8943f.tar.gz
gentoo-95dbbb03abae1ed4a2f92b9aed9a75bf55e8943f.tar.bz2
gentoo-95dbbb03abae1ed4a2f92b9aed9a75bf55e8943f.zip
app-admin/cdist: Bump version to 6.5.4
Signed-off-by: Jaak Ristioja <jaak@ristioja.ee> Closes: https://github.com/gentoo/gentoo/pull/15561 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-admin/cdist')
-rw-r--r--app-admin/cdist/Manifest1
-rw-r--r--app-admin/cdist/cdist-6.5.4.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-admin/cdist/Manifest b/app-admin/cdist/Manifest
index c718b4963c0f..97e2f22bcd90 100644
--- a/app-admin/cdist/Manifest
+++ b/app-admin/cdist/Manifest
@@ -1,2 +1,3 @@
DIST cdist-5.1.3.tar.gz 915245 BLAKE2B 5fce58f6fcbd48852e1c0c5568b72c360e74fd49b5321e2aedfdc8e48fd090cbdd7bab87a94e76d087f04f5a706bf2c7b1bebdc5a80867e26d8cc6e28afdeab3 SHA512 8330a5af80dfc07da722675ae1d402ebae4ba0aada451a02d782365d68d1d43a643609f3326f5ed793d2902838ee29071c0255c9d8a9d38c1e8a7c92a24cef46
DIST cdist-6.0.0.tar.gz 934813 BLAKE2B 3cb18ebb3059fc9a37beb1567c691e1d34a9cde5d49081e8798b5ba86ea8da3b6c964d2c8bea7bf2f04f986b0b4a8766c8ea53ce48fb4bc024264e72efec1fcb SHA512 e846060f3020d6281d41e97b9cc33250cd1d4ae0d110a2792fc2447af110fef91199fc0382d5a1e501f487fda42f703957ff5a39cf28061338609a600290d792
+DIST cdist-6.5.4.tar.gz 898002 BLAKE2B b4565cd8112ce1bff6ac74625a5920886a708fec827f70c3a3a2df156408761badebff4e161900cd09685bfbbb4954927c9771f6516c54a510b582ebec075e76 SHA512 3f1405e1b28d7568ef3ae543d59e760b2dc1fc8004be031550ba52d3aa2d8911cef4325865fb9ed5df053ec1609a076bb31a520b100bad5811f0de9cd73f416e
diff --git a/app-admin/cdist/cdist-6.5.4.ebuild b/app-admin/cdist/cdist-6.5.4.ebuild
new file mode 100644
index 000000000000..5d9c88fd9360
--- /dev/null
+++ b/app-admin/cdist/cdist-6.5.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A usable configuration management system"
+HOMEPAGE="https://www.cdi.st/ https://code.ungleich.ch/ungleich-public/cdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/dist/html/*.html docs/dist/html/man{1,7}/*.html )
+ distutils-r1_python_install_all
+
+ doman docs/dist/man/man1/*.1 docs/dist/man/man7/*.7
+}