summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/cgmanager/cgmanager-0.37.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/cgmanager/cgmanager-0.37.ebuild')
-rw-r--r--app-admin/cgmanager/cgmanager-0.37.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-admin/cgmanager/cgmanager-0.37.ebuild b/app-admin/cgmanager/cgmanager-0.37.ebuild
new file mode 100644
index 000000000000..fad5d258467e
--- /dev/null
+++ b/app-admin/cgmanager/cgmanager-0.37.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Control Group manager daemon"
+HOMEPAGE="https://linuxcontainers.org/cgmanager/introduction/"
+SRC_URI="https://linuxcontainers.org/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ sys-libs/libnih[dbus]
+ sys-apps/dbus"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # systemd expects files in /sbin but we will have them in /usr/sbin
+ pushd config/init/systemd > /dev/null || die
+ sed -i -e "s@sbin@usr/&@" {${PN},cgproxy}.service || \
+ die "Failed to fix paths in systemd service files"
+ popd > /dev/null || die
+}
+
+src_configure() {
+ econf \
+ --with-distro=gentoo \
+ --with-init-script=systemd
+}
+
+src_install () {
+ default
+ # I see no reason to have the tests in the filesystem. Drop them
+ rm -r "${D}"/usr/share/${PN}/tests || die "Failed to remove ${PN} tests"
+ # FIXME: openRC init scripts are not well tested
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newinitd "${FILESDIR}"/cgproxy.initd cgproxy
+}